0

I have two computers running 14.04 where I use Byobu with tmux backend. The difference between both is that one uses an existing home directory that was backed up and transfered to a fresh installation while the other one is a completely new installation.

The issue: Both Byobu statusbars look different

enter image description here

It's not only the yellow background that is different on the completely new installation on the lower bar in the image, but also the font weight and font color. If you look even closer, you find that GHz, G and seemingly % aren't bold on the lower bar.

Attempted troubleshooting

  • Read: How do I reset Byobu's settings?
    • Tried deleting both ~/.byobu folders.
    • Tried configuring with byobu-config and byobu-select-profile.
    • Purged and reinstalled Byobu on the machine that shows the upper statusbar.
  • Tried searching with find for tmux and byobu in /usr and /home/$USER to find related files, but no luck.
  • Searched for differences in backups of both ~/.byobu folders. Still no luck.
  • Restarted gnome-terminal and Byobu instances several times.

Further details

The upper statusbar is directly from my desktop, while the computer giving me the lower statusbar is connected via SSH. I assume that this doesn't make any difference. As written above, the terminal client is gnome-terminal, background transparency is disabled and both gnome-terminal instances have the same color profile loaded.

It feels like I'm missing something obvious, but I'm currently at my wits' end.

Question: How to get a consistent statusbar?

Or more precisely: How can I get a consistent default Byobu statusbar displayed across machines?


Further investigation

In the mean time I found that, while I had reset the configuration, the custom Byobu prompt was not enabled. I ran byobu-enable-prompt to enable it. (This adds the line [ -r /home/$USER/.byobu/prompt ] && . /home/$USER/.byobu/prompt #byobu-prompt# to ~/.bashrc)

I found that there exists /usr/bin/byobu-status-detail which gives a detailed overview about the configuration and compared portions of if like for the load average:

#[default]#[fg=black,bg=brightyellow]6.53#[default]#[fg=\#EEEEEE]#[bg=\#333333]
        (load_average)
        6.53 5.93 5.87 8/1066 27196

#[default]#[fg=black,bg=brightyellow]0.00#[default]#[fg=\#EEEEEE]#[bg=\#333333]
        (load_average)
        0.00 0.01 0.05  2/444 3717

Strangely, there is no difference there. Dug a little bit further around in /usr/lib/byobu and /usr/share/byobu.

A hint at the solution

However, when I switched to the other machines desktop and connected to both Byobu instances everything was as it should be! This is interesting.

1 Answer 1

0

Looks like this was an issue with rotten default settings of gnome-terminal. I opened Profile Preferences from the Edit menu, went to the Compatibility tab, clicked Reset Compatibility Options to Defaults, closed the running terminal and opened a new one. Now the issue is gone.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .