0

Using rsnapshot with the +rsync_long_args=--rsync-path="sudo rsync" command fails with a rsync not found error. If I do a rsync only without using rsnapshot the command works find so it's not related to rsync. In addition if I install rsnapshot on a 12.04 server this issue does not occur even when pulling form the same server.

I believe this is a bug introduced into 14.04 with rsnapshot as I've removed the package from the 14.04 server and cloned the rsnapshot github repo and installed rsnapshot with it and the issue is no longer.

Not sure if it relates to the downstream Debian package/bug of this: Debian Bug report logs - #743310

Has anyone else had this issue and can they confirm the issue? If so I will submit a bug report, but just wanted to be sure before doing so.

Thanks

  • Do you get an error with ssh host sudo id and then ssh host sudo rsync – bain Jun 20 '14 at 10:09
  • No it only error's when running rsnapshot. For example I can successfully run: rsync -aPe ssh --rsync-path="sudo rsync" user@remoteserver:/etc /rsnapshot/remoteserver – Keith Pawson Jun 20 '14 at 12:48
  • I should also add that I've just ran some tests with VM's plain vanilla 12.04 server and plain vanilla 14.04 server and the 12.04 works fine, but 14.04 won't run with that rsync option. – Keith Pawson Jun 20 '14 at 12:50
  • The upstream bug report does appear to be relevant. You could try recompiling without 10_space_destdir.diff to verify if it fixes the issue, and email the Debian maintainer if the bug is going to be fixed. – bain Jun 20 '14 at 15:41
  • Thanks, if I get time over the weekend will try. In the meantime I've submitted a bug report on Launchpad to the rsnapshot package. – Keith Pawson Jun 21 '14 at 0:49
1

Bug confirmed in 14.04 see https://bugs.launchpad.net/bugs/1332753

Installed from git repo to have rsnapshot working in 14.04 e.g.

sudo apt-get remove rsnapshot git clone https://github.com/DrHyde/rsnapshot ./configure --sysconfdir=/etc sudo make test sudo make install

sudo cp /etc/rsnapshot.conf.default /etc/rsnapshot.conf

Rsnapshot will now work with the +rsync_long_args=--rsync-path="sudo rsync" command.

Not the answer you're looking for? Browse other questions tagged or ask your own question.