2

Having not used Ubuntu in over 5 years, my curiosity got the better of me. I've dual booted Ubuntu 14.04 alongside Windows 8.1 on my Surface Pro. Only just installing it yesterday, being the noob that I am, it took me awhile to get it looking the way I wanted.

While still trying to edit things around today, under the terminal I tried to press "~" on the onboard keyboard for file directory stuff. That's when the onboard keyboard decided not to work anymore. The keyboard itself pops up and you can see the keys being pressed but it doesn't actually type anything.

I've tried googling my issue but it seems that no one else is suffering the exact same problem. I have no problems with using a mouse (or using the touch screen), it's just the onboard keyboard that's giving me issues...

So my question is, does anyone have a solution for my problem? I'd like to keep using Ubuntu but not being able to type whatsoever makes the OS almost useless.

EDIT: Tested an USB wireless keyboard on my brother's system (exactly the same as mine) and it works not a problem but on mine, nothing is outputted.

EDIT EDIT: Typing works perfectly under guest but not my account...

3

The issue was that slow keys was on.

Turning them off under System Settings > Universal Access > Typing fixed the whole keyboard issue.

  • Was not my issue, I think something is broken in GNOME. Signed, a frustrated programmer with a broken enter key. – dmanexe Jun 16 '18 at 15:15
0

WARNING: This will reset most settings you made in System-Settings

NOTE: Personal data won't be touched, but I do not guarantee anything.

As typing works perfectly when you log in as guest it is likely that some configuration files (in your home directory) got messed up (which is strange). You could try to delete/rename the configuration files in your home directory; you will need a USB keyboard.

As your keyboard doesn't work when you are logged in, log out. Then press the keys ctrl+alt+F1. You will be presented a command-line login-prompt. Log in using your username and your password (note: there are no dots or stars or something for every key you press when you enter your password).

Then enter the following commands:

mv .config .config_old
mv .cache .cache_old
mv .gconf .gconf.old

These commands rename all configuration files. (e.g. .config becomes .config_old)

Now you can switch back to the GUI by pressing ctrl+alt+F7. Then log in as you would do normally. Your keyboard should now work again, but it will look like a completely fresh installed system.

Before beginning the configuration again, try to open the terminal and press '~'. If you get the same problem again, repeat the process of renaming the configuration files. You might then want to try a different on-screen keyboard. (If you get problems when typing '~' on a USB keyboard I have no idea what you could do expect not using '~', which would be unacceptable...)

0

The safest bet is to reset onboard settings to default using dconf-editor.

sudo apt-get install dconf-editor

You'll find onboard settings under org compartment.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.