0

I am trying to install Ubuntu 13.10 onto my new computer so I can dual boot with Windows 7. I already have Windows 7 on an SSD set to AHCI and it is in legacy mode. I am trying to install Ubuntu onto a hard drive, but have run into some problems. The first time I installed Ubuntu it wouldn't connect to a wired network, and it only ran in low graphics mode.

I wiped and reformatted the said hard drive after that and went for a second attempt, with no success. I have wiped the drive again and started over, except this time I decided to try Ubuntu instead of installing and from a live CD it immediately entered into low graphics mode. I did some research and found that my motherboard might be a problem.

Specs:

  • CPU: AMD FX-6300, 6-Core, 3.5 GHz
  • mobo: Gigabyte 990FXA-UD3 rev. 4.0 (Realtek GbE LAN chip)
  • GPU: Sapphire Radeon R7-260X 2GB
  • RAM: PNY XLR8 DDR3-1600 (8GB)
  • SSD: Kingston SSDNow V300 60GB (Windows 7 installed)
  • HDD: Western Digital Caviar Blue 500GB (future Ubuntu home)
  • HDD: Western Digital Caviar Blue 1TB (applications and stuff)

To the best of my knowledge the R7-260X graphics card and Linux should be able to work nicely together, yet whether I try or install Ubuntu I'm in low graphics mode. Is the motherboard hindering the entire process here? Is there a piece of the hardware that is preventing the kernel from seeing and recognizing the graphics card and network chip?

The closest answer I have found to this problem was Trouble Installing 12.10 on a GA-990FXA-UD3 Base Machine: Network and USB Don't Work.

I have tried setting the network stack to enable along with the iommu before the installation to see if that would work when just trying Ubuntu from the live CD, but that did not work.

Do I have to do a full install first, then change the motherboard options, or will I have to install Ubuntu, download the Realtek drivers from their website, and install via USB? Will I have to do the same thing for my graphics card?

I would like to eventually migrate to Linux full time or at least most of the time. I have messed around with Ubuntu on my old (8 years old) HP laptop, but if my hardware and software don't aren't compatible I don't know if that will be an option. I don't want to only use Ubuntu on outdated hardware with no real upgrade options. As I am new to the world of Linux, please be as direct and precise as possible about how to go about addressing these issues with my current hardware.

2

Here are some ways I have successfully booted the Ubuntu installation media on a computer with a similar motherboard.

  1. Ubuntu 13.10 64-bit minimal CD written to a USB flash drive, following the instructions here.

  2. Ubuntu 14.04 install from the Ubuntu 14.04 64-bit desktop iso file written to a USB flash drive, following the instructions here. The key to the success of this method was using the Ubuntu Startup Disk Creator application which is built-in in Ubuntu and also included in the Ubuntu live DVD. I tried using UNetbootin and also burning a DVD, and both of them didn't work. I strongly recommend that you either reformat the USB flash drive as FAT32 first with a partition editor like GParted to get rid of any existing bootloader garbage that you have already written to the USB flash drive or else use a new USB flash drive.

The same computer could not boot from the Ubuntu 13.10 Desktop iso file written to a USB flash drive.

Regarding the BIOS settings for the SSD, I used AHCI but not Legacy mode.

If you get a black screen or low-graphics mode message after you finish the installation and reboot, that probably means that you need to enter a text-only virtual console by pressing the keyboard shortcut Ctrl + Alt + F3, login at the login: prompt with your username, login at the password: prompt with your user password, and install the fglrx proprietary driver for your Sapphire Radeon R7-260X graphics card with sudo apt-get install fglrx fglrx-amdcccle && sudo reboot.

0

I have the 990FX and I've noticed that it's just generally finicky. I took too long to respond to this after "fixing" it, so I forgot all I did, but when you change settings, it likes to pretend you didn't do anything. I find that it's kind of like just restarting your computer; write down the settings you want, reset BIOS settings to default in the menu you're using. (I didn't clear CMOS/move jumper. I pressed the default button in the BIOS software), and then boot Ubuntu w/ default settings. Now, restart into the BIOS settings and fix them to your preference, and boot Ubuntu again. This has worked at least once for me. If I have any updates hopefully I'll update this. (no promises)

0

another solution which could may be help... I got a GA-990FXA-UD5 Gigabyte motherboard. It was impossible to install Fedora or Debian as the screen turned black during the installation boot. I exchanged display port with Dvi plug and it works. I hope it can help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.