I am running Ubuntu 14.04 on my Lenovo Thinkpad T530. I noticed that if I suspend the laptop at some point, the next shutdown will instead cause a restart.

It seems that I am not alone with this (and many other questions), and I tried most solutions I could find, but nothing worked.

So far the best (or only) working solution was to boot with acpi=noirq. This fixes the issue, but then suspending the laptop doesn't lock it. There may be other side-effects which I haven't found as I don't understand the implications of this kernel parameter.

What does acpi=noirq do, exactly? How can I lock the computer on suspend? Is there another solution?

Things I have tried:

  • sudo ethtool -s eth0 wtol d (no effect)
  • sudo apt-get install laptop-mode-tools (doesn't shut down correctly anymore at all)
  • Deactivating "Wake On LAN" in my BIOS (no effect)
  • Try to shut down with sudo shutdown now and similar (no effect)

You can try this instead it near common to all Linux

sudo init 1 (restart)

sudo init 0 (shutdown)

  • This isn't really a fix, it's a somewhat questionable workaround for me (if it even works – I haven't tried it). I'd rather try to fix the actual issue. – Ingo Bürk Jun 21 '14 at 15:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.