0

I'm getting this error

New software can't be installed, because there is a problem 
with the software currently installed. Do you want to 
repair this problem now?

And other than this error message popup has only two button. "cancel and "Repair"

And when I click repair, same pop up comes back.

My Ubuntu version is 14.04 LTS

jitendra@jitendra-Dell-System-XPS-L502X:~$ sudo apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  cli-common libmono-corlib4.5-cil libmono-i18n-west4.0-cil
  libmono-i18n4.0-cil libmono-security4.0-cil
  libmono-system-configuration4.0-cil libmono-system-security4.0-cil
  libmono-system-xml4.0-cil libmono-system4.0-cil libthunarx-2-0
  libtumbler-1-0 mono-4.0-gac mono-gac mono-runtime mono-runtime-common
  mono-runtime-sgen thunar-data tumbler tumbler-common xfdesktop4-data
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 230 not upgraded.
1 not fully installed or removed.
Need to get 0 B/110 kB of archives.
After this operation, 0 B of additional disk space will be used.
dpkg: error processing package libmono-security4.0-cil (--configure):
 package libmono-security4.0-cil is not ready for configuration
 cannot configure (current status `half-installed')
E: Sub-process /usr/bin/dpkg returned an error code (1)

jitendra@jitendra-Dell-System-XPS-L502X:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  cli-common libmono-corlib4.5-cil libmono-i18n-west4.0-cil
  libmono-i18n4.0-cil libmono-security4.0-cil
  libmono-system-configuration4.0-cil libmono-system-security4.0-cil
  libmono-system-xml4.0-cil libmono-system4.0-cil libthunarx-2-0
  libtumbler-1-0 mono-4.0-gac mono-gac mono-runtime mono-runtime-common
  mono-runtime-sgen thunar-data tumbler tumbler-common xfdesktop4-data
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 230 not upgraded.
1 not fully installed or removed.
Need to get 110 kB of archives.
After this operation, 0 B of additional disk space will be used.
Get:1 http://ubuntu.uhost.hk/ trusty/main libmono-security4.0-cil all 3.2.8+dfsg-4ubuntu1 [110 kB]
Fetched 110 kB in 1s (86.9 kB/s)                
dpkg: error processing package libmono-security4.0-cil (--configure):
 package libmono-security4.0-cil is not ready for configuration
 cannot configure (current status `half-installed')
E: Sub-process /usr/bin/dpkg returned an error code (1)
0
1

Just remove the partially installed package libmono-security4.0-cil and then fix the dependencies,

sudo apt-get purge libmono-security4.0-cil
sudo apt-get install -f
3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.