0

I need to downgrade to PHP 5.3 to use some older scripts. I've tried phpfarm and phpbrew, but I couldn't get either of them to work. I've also tried the solutions listed here: Installing PHP 5.3 in Ubuntu 14.04

I'm running a LAMP setup on 14.04.

Is there any way or would I be better off using a different version of Ubuntu?

  • In what way did the answers in the linked question not work for you? – Adaephon Jun 20 '14 at 6:22
1

You could go with Ubuntu 10.04 Lucid. Security support runs out for that in less than a year, but that should give you enough time to patch your PHP.

In my opinion using an Ubuntu-supported package is preferable to compiling from source, and 10.04 does happen to have the version you want as its official package.

Eventually you are going to have to patch your PHP code, however. It shouldn't be that difficult to bring it into compatibility with later PHP versions: all issues will be well documented online, and there will only be a small number of issues that would affect backward compatibility. Older versions of PHP won't be supported forever and eventually you'll end up with security problems if you stick with PHP versions that are not officially supported.

  • Yeah, this is most likely what I will do if I can't get it to work with VirtualBox. – Medinita Jun 20 '14 at 20:57
0

I think you'd uninstall PHP and then get the 5.3 source file and compile it by extracting the .tar, going into that directory, and running "make install clean"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.