1

I need to install the ATI proprietary driver on my laptop (Asus K54HR) as I use it for gaming. My problem is, it doesn't matter what I try, I have always the same result black screen and I have to reinstall ubuntu. It works fine with external monitors but not with the laptop screen. I use Ubuntu 14.04 in dual boot with windows 7 both 64bit. I tested it with 12.04 64 bit too. My graphic card is Radeon HD 7470M Seymour series. What can I do?

Thank you.

  • What method did you try to install the driver? When are you getting the black screen? – kraxor Jun 19 '14 at 19:43
  • I've tried: GUI installation Manual Installation creating Ubuntu package and I always have the black screen as soon as I reboot the system – LupusInFabula Jun 19 '14 at 19:45
  • Do use use Ubuntu for gaming? Or jus windows? If just windows then you only need to install the driver on windows – OverCoder Jul 29 '14 at 22:25
0

First, make sure you're using the latest driver version from AMD. If those aren't working, I would recommend trying the "Latest Beta" drivers. At this point in time, the release notes for the Beta version mention "Ubuntu 14.04 Support", so it might be a good idea especially to try those. (I don't know if it was already there, or what "Ubuntu 14.04 support" means exactly, or what.)

Anyway, when you extract the .zip file and install the Beta driver (try the normal install and the package generation), it still might not be working. If it isn't, reboot into a Recovery Mode root shell prompt (howto) and run:

aticonfig --initial

and then reboot with reboot or Ctrl + Alt + Del.

However, I would be very surprised if the package generation method doesn't make an xorg.conf for you.

  • If my solution doesn't work, put the output of dmesg | grep fglrx into your question. – Richard Jun 19 '14 at 20:24
  • black screen, it does not start even with fail safe graphic so I cannot try dmesg | grep fglrx – LupusInFabula Jun 21 '14 at 17:39
  • Even a recovery mode root shell prompt? – Richard Jun 21 '14 at 18:43
  • I've tried connecting an external monitor, and everything works fine! so the problem must be my laptop screen. as per the dmesg here the result: – LupusInFabula Jun 22 '14 at 11:35
  • [ 13.851841] fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel. [ 13.866332] fglrx: module verification failed: signature and/or required key missing - tainting kernel [ 13.876406] <6>[fglrx] Maximum main memory to use for locked dma buffers: 3766 MBytes. [ 13.876704] <6>[fglrx] vendor: 1002 device: 6760 count: 1 [ 13.877101] <6>[fglrx] ioport: bar 4, base 0xd000, size: 0x100 [ 13.877304] <6>[fglrx] Kernel PAT support is enabled [ 13.877332] <6>[fglrx] module loaded - fglrx 14.20.7 [May 22 2014] with 1 minors – LupusInFabula Jun 22 '14 at 11:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.