4

I have just moved back to Ubuntu from Windows 7 and a few months ago, I bought a NETGEAR WNA3100 wireless adapter because my old adapter had broken. I plugged in my adapter and it doesn't seem to work, I also used the windows 7 drivers for it and tried them on the program "Windows Wireless Drivers" and they don't seem to recognize the device. However I have heard you need XP drivers but I can't seem to find them on the internet nor find them on the CD.

Could anyone help me get my wireless adapter to work? Any help is greatly appreciate.

P.S I do have internet connection though I have to tether my phone to my computer and then connect my phone to my router.

  • 1
    Which Ubuntu version? 11.10, 11.04, 10.10, 10.04 LTS – david6 Nov 28 '11 at 19:27
  • What is the output from: sudo lshw -C network and iwconfig? – david6 Dec 2 '11 at 21:21
  • If anyone is looking for an answer in 2016, i had the same issue and followed the steps from github.com/jurobystricky/Netgear-A6210 and it resolved the issue. – Michael Cera Sep 16 '16 at 6:01
3

I had exactly the same problem with my WNA3100 and Ubuntu 11.04 After two weeks of trying all suggestions I could find on the net, I succeeded. I hardly know anything about Linux and found it quite simple. You just need the right driver.

Do the following step by step:

  • plug in the wna3100

  • open the terminal and type: lsusb

  • hit enter, you should see something like this:

    Bus 001 Device 002: ID 0846:9020 NetGear, Inc.
    
  • if the answer is yes go on with the following

  • create a folder somewhere you could find it easily (name it wifi driver or so)

  • download the driver from here: (just copy the url, paste it in your web browser and hit enter if the link doesn't work)

    http://media.cdn.ubuntu-de.org/forum/attachments/2612284/Broadcom_bcm43xx_USB_32_64bit_v2.tar.gz

  • You will get a box that ask to open or save the driver file

  • open it with whatever program you use to unzip (or save it somewhere and unzip it from there)

  • unzip it to the folder you created in the first step

  • right click both .inf files, go to tab 'rights' and click on the make file executable box (mine is in dutch so I don't know if the translation is right)

  • close that window

  • do the same for the .sys files

  • now open the windows wireless driver program (download it from ubuntu software center if you don't have it)
  • browse the .inf file with that program and click install.
  • never erase the folder where the .inf and .sys files are found
  • pull out the wna3100
  • reboot your computer
  • plug in the wna3100, when it stops blinking open the network manager.
  • You should be able to see your wireless network.
  • if yes, then jump up like me and shout yeehaah (or something alike)
  • if not, i feel really sorry for you, but somehow this worked for me and my ubuntu 11.04.
  • Hans Verboven: By "windows wireless driver program" I am assuming you mean ndiswrapper? I cannot get it to install at all. Keeps telling me it can't find the package when I know it is there. – user38831 Dec 21 '11 at 21:08
  • 1
    Damn, link 404s. Was promising, too. – Kzqai Sep 4 '12 at 13:19
  • I think this is the same one: media.cdn.ubuntu-de.org/forum/attachments/06/41/… – Tyler Biscoe Oct 6 '13 at 23:37
  • 1
    Link in answer outdated. – ThisIsNotAnId Jan 31 '17 at 4:52
3

Actually an open source driver has been developed for the Netgear A6210 that also works for the Netgear WNDA3100v3. While I'm not sure which version you have, I know from experience that this driver also works for the v3:

https://github.com/jurobystricky/Netgear-A6210?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.