36

I would like to know how to properly install, and use texlive along with the package manager tlmgr in Ubuntu. Here is what I did to install texlive:

sudo apt-get install texlive-latex-base texlive-latex-extra texlive-latex-recommended

And now I do have texlive, but the package manager is not working. Following is the error

sudo tlmgr update -all
(running on Debian, switching to user mode!)
cannot setup TLPDB in /home/kniwor/texmf at /usr/bin/tlmgr line 5336.

Is there a better way to install texlive? What can I do to fix the package manager at this point?

  • 1
    If you do not have any space issues you can go ahead and install the full texlive package: sudo apt-get install texlive-full – D-unit Jun 19 '14 at 14:32
  • Thanks. However I prefer to install only what I need. Mostly because I like to know what I'm using since I use multiple computers to compile my files(work/home etc) and some of them have space issues. – ste_kwr Jun 19 '14 at 14:35
  • See also: tex.stackexchange.com/questions/114623/… – landroni Jan 7 '15 at 16:59
47

Just run tlmgr init-usertree first and then run sudo tlmgr update --all.


Maybe you will get:

/usr/bin/tlmgr: Initialization failed (in setup_unix_one):
/usr/bin/tlmgr: could not find a usable xzdec.
/usr/bin/tlmgr: Please install xzdec and try again.
Couldn't set up the necessary programs.
Installation of packages is not supported.
Please report to texlive@tug.org.
tlmgr: exiting unsuccessfully (status 1).

If so, you have to install the xzdec package, from your package manager or through sudo apt-get install xzdec.


To use the GUI, you also need to install perl-tk:

sudo apt-get install perl-tk

Then you can summon the GUI via:

tlmgr --gui

And then hit the Load Default button.

  • 5
    This works fabulously. – ste_kwr Jun 23 '14 at 18:24
  • TeXLive 2013 version included in Ubuntu 14.04 may stop working with tlmgr, since TeXLive 2014 was released in the meantime. See: askubuntu.com/questions/486170/… – landroni Jan 7 '15 at 19:24
  • I was missing the xzdec package on a fresh installation of 16.04. Worked fine afterwards! – Daniel Jul 6 '16 at 17:34
1

If you want to use tlmgr on Ubuntu you basically have two options:

  1. Install texlive from scratch and create a dummy package

  2. Use install-tl-ubuntu, as described in this answer on tex.SE

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.