When I lock the screen (Super+L or Ctrl+Alt+L) and wait until the screen goes dark, I can't resume anymore. I move my mouse and press my keyboard, but screen stays blank. My monitor goes into standby mode, if I turn it off and on again it says "no input".

I suppose that pressing any keyboard key or moving the mouse doesn't wake it up because the keyboard is not working. The caps lock and num lock buttons don't light up when I press them (they usually do). Why is the keyboard turned off when screen is locked?

It's Ubuntu 14.04 on a DELL Optiplex GX620, the mouse is wireless (Logitech Unifying Receiver) and the keyboard is connected via USB. I tried connecting a different mouse or keyboard to a different port. The mouse's red laser at the bottom does light up, but the PC does not resume.

I have used Debian Sid, Arch Linux and elementaryOS on this computer before Ubuntu, and this problem did not occur. Ubuntu is the only distro which locks the screen with LightLocker, so maybe the problem is with LightLocker...

The weird thing: This does not happen if I leave the PC alone and wait until it locks itself automatically! Only if I manually lock it.

Edit: I can't access TTY1-6 either.

  • Try pressing the brightess up button on your keyboard if you have one Jun 19, 2014 at 14:16
  • @DusanMilosevic No, it's a PC...
    – Lesik2008
    Jun 19, 2014 at 14:58
  • OK, some keyboards have that button, it doesn't matter if you connect it to laptop or PC. If you don't have that button, that's OK. I am experiencing similar issue, and I'm solving it by pressing brightness button(up or down). Jun 19, 2014 at 17:06
  • 1
    I have this same issue. Except that it doesn't matter whether it locks automatically or I lock it manually - if I leave it locked long enough, I won't be able to turn it back on. I'm using the 3.16.3 kernel on 14.04.
    – jcora
    Sep 20, 2014 at 11:50

1 Answer 1


I had similar issues with Ubuntu 14.04 and 16.04 more recently.

After struggling for a while, I found that disabling USB auto suspend, solved (worked around) the problem.

This feature is a part of usbcore which is compiled in the kernel in Ubuntu.

From https://unix.stackexchange.com/a/175035,

Edit the /etc/default/grub file and change the GRUB_CMDLINE_LINUX_DEFAULT line to add the usbcore.autosuspend=-1 option:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash usbcore.autosuspend=-1"

Note that quit splash were already present options. So keep other options you have too.

After save the file, update grub:

sudo update-grub

And reboot.

Now check autosuspend value:

cat /sys/module/usbcore/parameters/autosuspend

And it should display -1.

  • This answer is correct for Ubuntu Budgie 18.04
    – Marecky
    Jul 9, 2018 at 12:16
  • Also true for Ubuntu Budgie 19.10
    – Learning
    Jan 30, 2020 at 6:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.