I created an extended partition and tried to add two NTFS units to it. Instead two 125 GB partitions, I got – according to Disk Utility – 2 X 982 GB partitions plus a 14574534 TB one (wahey!). I don't remember to have done anything weird.

The case is:

  • Neither Disk Utility, GParted or fdisk will let me fix/delete the extended partition, and in addition,

  • My LiveCD won't boot, although the BIOS order is correct and it worked perfectly before Ubuntu was installed. The hard drive installation of Ubuntu will start instead (edit – I got it to boot but having the drive unmounted does not fix the issue).

I guess I could try even more tools but I don't think this is that much of an unusual problem... what's the straight-forward solution for this?

Thank you in advance.

  • 5
    Cosmic background radiation. No joke. Per second in an area of your hand approx. 10 high energetic particles hit. If they decay there, they can reverse bits. It's a wonder pcs even work from time to time. But in your case - more likely a software bug. That error sounds familiar. – con-f-use Jun 13 '11 at 17:38
  • 6
    Well at least you can actually download the whole internet and sync with everyone. – Luis Alvarado Jun 13 '11 at 17:53
  • You own a very special kind of business-class HDD, meant for politicians and CEOs. It has virtually unlimited "budget", but its definately corrupted :P – MestreLion Jun 13 '11 at 20:19

I hope this may help you. http://tutafuta.com/2011/03/15/partition-table-repair-reinstall-copy-for-future/

  • Unfortunately it didn't... – deprecated Jun 13 '11 at 22:50

If the CD doesnt work did you try to create a live usb stick and start a session using the usb stick?

  • I finally got the CD to work (well, it started to do for no good reason) but this isn't allowing me to delete the partition :( – deprecated Jun 13 '11 at 22:45

Okay so I managed to fix this, but in a pretty heterodox way I think.

As I said, my problem in particular consisted in an extended, infinisized-yet-empty, useless partition that couldn't be deleted with any of the usually recommended GNU tools for these cases.

It could be deleted with the Windows 7 installer. However, this messes up the whole partition table so you need to recover it using testdisk (no, I couldn't do this before the delete).

After this, you need to recover your GRUB with a CD or so.

I hope this helps someone in the future.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.