18

I don't understand this error from the Startup Disk Creator:

org.freedesktop.DBus.Python.AttributeError: Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/dbus/service.py", line 707, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/share/usb-creator/usb-creator-helper", line 218, in Format
    parent_dev = _get_parent_object(udisks, device)
  File "/usr/share/usb-creator/usb-creator-helper", line 49, in _get_parent_object
    parent = partition.get_cached_property('Table').get_string()
AttributeError: 'NoneType' object has no attribute 'get_cached_property'

What does this mean? I only want to erase the 2GB MP3 player in order to put the iso on there. The disk creator requires this step.

1
  • 1
    unmounted and remounted, formatted as fat 16, then fat 32. seems to be working. not sure why it wasn't. gparted to the rescue. – Thufir Jun 19 '14 at 6:33
34

This is a known bug: https://bugs.launchpad.net/ubuntu/+source/usb-creator/+bug/1294877

There are several workarounds but the one that worked for me was to right click on the .iso in the file explorer and select 'Open With Disk Image Writer' and then 'restore' the ISO image to the selected USB device.

enter image description here

4
  • 1
    Nice! didn't even know about this. – Yanick Rochon Sep 24 '14 at 14:06
  • 2
    Neither did I until I found it by blundering about trying to fix my Ubuntu install :) – Thomas Bratt Sep 24 '14 at 14:23
  • 1
    interesting. It used to work fine, so somebody must have fixed it so it works better now. The end result is you really just have to use a different program. The problem isn't really getting solved, one just has to avoid it. I guess you get what you pay for. Although I find the paid stuff isn't much better. :-( – stu Jun 13 '15 at 16:37
  • 1
    I experienced the same error. When I played around and formatted the disk with fat I was able to run the startup disk creator without any issues. – Marco Pashkov Mar 23 '16 at 6:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.