avconv used to work fine for me in 13.10, but now it doesn't. I'm using it in the same way as before, for example:

avconv -ss 1971 -t 2216 -i x.mp4 -vcodec copy -acodec copy -metadata track="7"  "d32.mp4"

terminal output:

avconv version 9.13-6:9.13-0ubuntu0.14.04.1, Copyright (c) 2000-2014 the Libav developers
  built on May  9 2014 13:34:03 with gcc 4.8 (Ubuntu 4.8.2-19ubuntu1)
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'x.mp4':
    major_brand     : isom
    minor_version   : 512
    compatible_brands: isomiso2avc1mp41
    encoder         : Lavf55.12.100
  Duration: 01:06:14.76, start: 0.000000, bitrate: 848 kb/s
    Stream #0.0(und): Video: h264 (Main), yuv420p, 854x480, 716 kb/s, 25 fps, 25 tbr, 90k tbn, 50 tbc
    Stream #0.1(und): Audio: aac, 44100 Hz, stereo, fltp, 125 kb/s
Output #0, mp4, to 'd32.mp4':
    major_brand     : isom
    minor_version   : 512
    compatible_brands: isomiso2avc1mp41
    track           : 7
    encoder         : Lavf54.20.4
    Stream #0.0(und): Video: libx264, yuv420p, 854x480, q=2-31, 716 kb/s, 90k tbn, 90k tbc
    Stream #0.1(und): Audio: aac, 44100 Hz, stereo, 125 kb/s
Stream mapping:
  Stream #0:0 -> #0:0 (copy)
  Stream #0:1 -> #0:1 (copy)
Press ctrl-c to stop encoding
frame=50092 fps=6618 q=-1.0 Lsize=  197157kB time=2003.60 bitrate= 806.1kbits/s    
video:165125kB audio:30720kB global headers:0kB muxing overhead 0.670179%

The length of the output should be 4 minutes and 5 seconds, but it is over 30 minutes. Does any one know what is going on or have a suggestion?

  • Try downloading the most recent static build of ffmpeg from the FFmpeg Dwonload page. I'm interested to know if it works as expected. – llogan Jun 19 '14 at 5:48
  • It has the same problem. – fadiak Jun 19 '14 at 18:29
  • Thanks for trying. Can you show the command and the complete console output? ...and only now do I realize my typo in the first comment. – llogan Jun 19 '14 at 18:40

I used -t as an ending time instead of a duration.

The correct way to use -t is to specify how long should the output video be, in other words in this case the value in the parameter -ss needs to be substituted.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.