8

I am running VMware with Ubuntu 14.04. The host operating system is Ubuntu 14.04, and the guest is Windows 8.1 Pro. When I briefly press the super key from within VMware, Ubuntu displays the keyboard shortcut overlay, and it does not go away. How do I stop this from happening?

  • Note: It will go away if you focus your mouse to the launcher and then press the super key again. – jobin Jun 20 '14 at 10:03
  • VMWare is a company, which software are you using Player, Workstation, Fusion, etc? – jobin Jun 22 '14 at 10:16
  • This seems to be a VMWare bug in guest isolation on Linux. I observe the same behaviour with Ubuntu 14.04 (Host) and Windows 10 (Guest). – Alexander Rechsteiner Aug 1 '15 at 19:37
  • Another possible solution: askubuntu.com/a/756509/250300 – Melebius May 17 '17 at 7:29
7

Pressing the Super key invokes the Unity Dash.

Pressing and holding the Super key invokes the keyboard shortcut overlay.

I suspect you are doing the later, based on your description.

Nevertheless, you could change the key used to invoke the Unity Dash using Unity Tweak Tool. This way, VMware will get your key-press signal immediately, when you press Super.

  1. Install Unity Tweak Tool

    sudo apt-get install unity-tweak-tool
    
  2. Launch Unity Tewak Tool.

  3. In the Unity section, select Additional.

  4. Click on <Super> next to Show the launcher.

  5. Select a different key (or key-combination) to invoke the launcher.

| improve this answer | |
  • I think you have it backwards. He says "when I briefly press the super key". I have this problem too, and it is incredibly annoying. As far as I can tell there is no way to disable it. I am on a Mac and if I "command-tab" to swithc out of VMWare to Mac OS X, it ALWAYS pops up the search bar in Ubuntu so when I go back I have to manually click on the window I was working on. It's enough of a problem to make me delete Ubuntu and go with another distribution. – Mike May 5 '15 at 23:33
  • This worked perfectly for me: Ubuntu 14.04 running VMWare Player with a Windows 7 VM (boo Windows! - contract requirement...) – sage Aug 26 '15 at 0:37
  • (On another laptop, I have decided I prefer the super key behavior in Ubuntu and I'm just limiting the time I spend in the Windows VM by ssh'ing into it...) – sage Sep 21 '15 at 20:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.