I have a Mac mini early 2007. I installed Ubuntu 14.04 LTS i386 without using the bootcamp and just erasing all partitions(I mean there is no OS X on disk but only Ubuntu.). I have had no problems. Everything is working perfectly but there is no sound. On the tray bar there is sound indicator and seems like sound is working but somehow I couldn't get sound from my speakers. At the System settings when I click Sound-->Test Sound, there is no sound. I searched on Google and found some articles. I tried them out but still no sound.

I tried typing this in a terminal:-

sudo nano /etc/modules

and added these lines to that file:-





but no fix yet. Also I tried alsamixer but it wont open stating:-

No such file or directory

I tried the solutions here but still no fix. Now What can I do to fix my sound ?

  • Welcome to Ask Ubuntu. Open a terminal with Ctrl+Alt+t and type alsamixer. You will get a terminal based tool for configuring your Sound card . Now try changing the settings there and get back to us. – VenkiPhy6 Jun 19 '14 at 3:37
  • Hi Venki, thanks for your kindly response when i type alsamixer and enter on terminal system says cannot open mixer: No such file or directory, i also tryed after sudo su and result was the same. – Sheshman Jun 19 '14 at 20:42
  • Whoa! That is the issue here i suppose. did you try sudo apt-get install alsamixer ?(i.e did you try installing alsamixer?) – VenkiPhy6 Jun 20 '14 at 1:42
  • yes i did, last night i google it the problem and found some articles about it, i try every step but the result is the same, is there any possibility to do something wrong during installation ? i mean should i try to format and re-install ? – Sheshman Jun 20 '14 at 4:17
  • "I try every step but the result is the same"- Which article did you exactly try out and what was the result of it exactly?(Add the info reg. this to your question's description) – VenkiPhy6 Jun 20 '14 at 9:08

Issue solved with USB Soundcard (12$).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.