5

I'm trying to install Ubuntu 14.04 on a Dell Inspiron 7537, in dual-boot with Windows 8.1, with a UEFI system. After the creation of the new partitions, I've been able to install Ubuntu 14.04 without any problem. It booted regularly, as far as I launched Windows again. Probably some program (McAfee?) has modified my EFI partition, and since that moment I've not been able to launch the "ubuntu" entry of UEFI anymore. GRUB failed to load, and the PC lauched the second option of UEFI, i.e. Windows 8.1.

Of course, I've tried to make a new installation of Ubuntu, but now I get this error when Ubiquity tries to configure Grub2:

grub-efi-amd64-signed failed to install into /target/.
Without GRUB boot loader, the installed system will not boot

and then Ubiquity crashes. At this point I tried to clean up the EFI settings using both efibootmgr on Ubuntu LiveUSB and EasyUEFI on Windows. These tools remove the entry correctly, but the problem remains unsolved.

Also Boot-Repair seems to fail, as when it asks me to launch

sudo chroot "/mnt/boot-sav/sda7" dpkg --configure -a

I get the same error:

Setting up grub-efi-amd64-signed (1.34+2.02~beta2-9) ...
Installing for x86_64-efi platform.
grub-install: error: cannot open `/boot/efi/EFI/ubuntu/shimx64.efi': Read-only file      system.
dpkg: error processing package grub-efi-amd64-signed (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 grub-efi-amd64-signed

I tried also to restore the laptop to factory settings, but fruitlessly.

It is very strange, as the first time everything worked perfectly. What can be my problem? Is there any way to delete all the references to Ubuntu from the EFI partition?

Thank you very much.

1
  • 1
    The linked answer is not really a duplicate of this one as it didn't even involve dual boot. It's possible the same cause was involved, but that's far from certain. Also, this question was asked long before the linked one.
    – mc0e
    Jan 26, 2020 at 15:19

2 Answers 2

3

Is there any way to delete all the references to Ubuntu from the EFI partition?

  • Boot via Live CD/USB
  • mount the EFI partition
  • delete the Ubuntu folder from the partition

... but, I would use Disks from Ubuntu Live to backup the partition to ISO first. So when you feel re-invigorated you can try bcdedit from within Windows. My HP Laptop will now no longer boot to Ubuntu without me changing the path of bootmgr as shown in the first answer here

As long as you have a backup of your EFI you can always return to prior state.

2
  • Ok. I've tried, but it seems that the filesystem is corrupted, or something like that. I am not able to do rm -rf /ubuntu, nor to see what is inside that folder. Strange characters appears with ls -l. Jun 19, 2014 at 10:09
  • That would also explain the boot issues.. Sorry I have not had to try to repair a partition yet.. Jun 19, 2014 at 17:41
0

First, and most importantly, disable Fast Startup in Windows. Some dual-boot instructions tell you to disable a similarly-named feature in the firmware, but that's often unnecessary and is not the same as disabling the Windows feature, whereas disabling the Windows feature is critical for safe dual booting. In your case, it's probably causing data corruption on the partition that holds the boot loader, thus preventing installation to it.

Second, try this:

  1. If you haven't already done so, disable Secure Boot.
  2. Download the USB flash drive or CD-R version of my rEFInd boot manager.
  3. Prepare a boot medium with rEFInd.
  4. Boot that boot medium. You should see a rEFInd menu with both Windows and Ubuntu options.
  5. Test that you can boot to both Windows and Ubuntu.
  6. Boot to Ubuntu.
  7. Do one of two things:
    • Install GRUB
    • Install the Debian-package version of rEFInd.

Which boot manager you install (GRUB or rEFInd) will determine which one you see when you boot. If rEFInd enables you to boot both Windows and Linux, then you know that it will work. GRUB will probably work, too, but without testing there's no way to be 100% sure of that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.