0

For any install in ubuntu It is giving the same error. How can I remove all these gstreamer package errors?

The error is

installArchives() failed: dpkg: dependency problems prevent configuration of gstreamer0.10-plugins-bad:
gstreamer0.10-plugins-bad depends on libdirectfb-1.2-0; however:
Package libdirectfb-1.2-0 is not installed.
gstreamer0.10-plugins-bad depends on libiptcdata0; however:
Package libiptcdata0 is not installed.
gstreamer0.10-plugins-bad depends on libjack0 (>= 0.118+svn3796); however:
Package libjack0 is not installed.
gstreamer0.10-plugins-bad depends on libmodplug0c2 (>= 1:0.7-4.1); however:
Package libmodplug0c2 is not installed.
gstreamer0.10-plugins-bad depends on libmpcdec3; however:
Package libmpcdec3 is not installed.
gstreamer0.10-plugins-bad depends on libmusicbrainz4c2a (>= 2.1.5); however:
Package libmusicbrainz4c2a is not installed.
gstreamer0.10-plugins-bad depends on libsoundtouch1c2 (>= 1.3.1); however:
Package libsoundtouch1c2 is not installed.
gstreamer0.10-plugins-bad depends on libssl0.9.8 (>= 0.9.8k-1); however:
Package libssl0.9.8 is not installed.
gstreamer0.10-plugins-bad depends on libwildmidi0; however:
Package libwildmidi0 is not installed.

libgstreamer-plugins-bad0.10-0 (0.10.22.3-2ubuntu2.2) breaks gstreamer0.10-plugins-bad (<< 0.10.22.3-2) and is installed.

Version of gstreamer0.10-plugins-bad to be configured is 0.10.18-1ubuntu1.
gstreamer0.10-plugins-good (0.10.31-1ubuntu1.2) breaks gstreamer0.10-plugins-bad (<< 0.10.21.2) and is installed.

Version of gstreamer0.10-plugins-bad to be configured is 0.10.18-1ubuntu1.
dpkg: error processing gstreamer0.10-plugins-bad (--configure):

dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
Errors were encountered while processing:
gstreamer0.10-plugins-bad
Error in function:

marked as duplicate by Zanna, Eric Carvalho, WinEunuuchs2Unix, Mitch Dec 22 '16 at 13:22

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    What is the output of "sudo apt-get -f install"? – Photon Jun 18 '14 at 5:12
  • Same As above , it is not installing in that case too . – user1813332 Jun 18 '14 at 5:36
1

This problem solved by using synaptic package manager . In synaptic package manager one of the option was broken packages . In that these gstreamer broken dependencies were present , by right click on them we can remove those dependences . After that everything is working fine with me .

Not the answer you're looking for? Browse other questions tagged or ask your own question.