0

With this tip I saw there is a total of about 60 applications being launched by startup applications, and at the moment I have to sit back and wait about 45s while the desktop is unresponsive...

How does startup applications work? can I tweak it in some way to make these apps start more gradually, not all together?

I don't want to disable any of them, just stop them all being loaded simultaneously and freezing the desktop

  • Not an answer to your question but a possible solution: switch to Xubuntu or Lubuntu. They are much more lightweight and run perfectly smooth on older computers. – kraxor Jun 18 '14 at 1:49
  • how many apps you have being started? or they dont use "startup applications"? I think there may have too much "iowait", the load goes to about 12 as I remember (4 cores).. – Aquarius Power Jun 18 '14 at 1:56
  • I only have 26 /etc/xdg/autostart/*.desktop files under Xubuntu 14.04. But if you have 4 cores, then I'm guessing you have a relatively new box, so the 45s startup time is way too much. Could you maybe post the results of ls -l /etc/xdg/autostart so someone can point out any anomalies? – kraxor Jun 18 '14 at 2:12
  • I fixed it! I will post how :) – Aquarius Power Jun 18 '14 at 4:01
3

First I saw this tip, but sleep 20;xscreensaver -nosplash seems not to work anymore on Ubuntu 14.04.

So I coded this script execLater.sh and put it at a place in my $PATH, chowned it root:root and mode permissions rwxr-xr-x, and put it on a fully root:root folder structure like /usr/local/bin.

sleep $1;shift;"$@"

So it sleeps before executing the command.

Show all hidden startup applications by following this tip

Now for each startup application.

If there is, for example, this:

xscreensaver -nosplash

change to this below, where "20" is the delay; I used up to "60" knowing I dont care much for some applications; and a minimum of "5" for the ones I care most.

execLater.sh 20 xscreensaver -nosplash

The tricky part

each of these below must have an exclusive delay of "1" because everything else depends on them

/usr/bin/gnome-keyring-daemon --start --components=secrets
/usr/bin/gnome-keyring-daemon --start --components=pkcs11
/usr/bin/gnome-keyring-daemon --start --components=gpg
/usr/bin/gnome-keyring-daemon --start --components=ssh
/usr/lib/unity-settings-daemon/unity-fallback-mount-helper
/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1
gsettings-data-convert
start-pulseaudio-x11
nautilus -n

My guess is, when all 60 apps startup at same time, these above take longer to complete and so the whole desktop stays unavailable...

If you log when each command was executed, you will understand what applications must have delay of "1", because all others are "actually only executed (?)" or "called?" after these; the above list is not fixed, it is just a tip, just logoff and login (no need to reboot to complete this list) so you can make the tests until you are satisfied with the results - now my desktop is available after only 5 seconds :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.