0

On Ubuntu 14.04 when I do any system intensive task like gaming and when temperatures reach over 80C for CPU and 70C for GPU, fan doesn't spin as fast as it does in Windows 7 under even lower temps. On Minecraft CPU quickly goes up to 85 and more but fan is still one level lower than it is under Windows 7 when CPU reaches 79C. I always thought that fan is controlled by BIOS because I couldn't control it in Win 7 but now it seems that OS can actually control it. I'm not sure about that though. Also, I can't control screen brightness when Ubuntu is powered on, but I can change it when the Acer logo on boot up is shown. Maybe fan and brightness have some connection in this issue.

My laptop:

Acer Aspire 5830G

i7-2620m 2.7ghz, GT 540M 2GB, driver 331.38, 8GB DDR3 1333

I really want to use Ubuntu instead of Windows but this prevents me from doing it completely. Does anyone know how to enable fan to spin as fast as it does in Windows?

Thanks in advance!

0

If you are running the Nouveau Nvidia drivers (what comes installed by default), try installing the current proprietary drivers.

In command line:

sudo apt-add-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install nvidia-current nvidia-settings

-Reboot your system-

Once you reboot, you can change your settings by running (in command line):

nvidia-settings

Note: Installing the proprietary drivers may correct the problem without you even having to run "nvidia-settings" and adjusting settings.

  • Thanks for reply. I'm already using proprietary Nvidia driver 331.38. I'll try different versions. – xfim Jun 18 '14 at 9:17
  • So I tried 304 driver but it doesnt work at all. Open source driver is for Intel GPU but the fan speed still doesnt change to max – xfim Jun 18 '14 at 10:27
  • FIXED!!! I had to disable acpi thermal module to let the bios control the fan, and now it goes full speed under load :) – xfim Jul 2 '14 at 21:39
  • Glad you got it working! Sorry, I've been away from computing for a while. Wish I could have been more help. – Cavaticus Jul 17 '14 at 1:40
  • It's ok. Atleast you replied with possible fix :) – xfim Jul 19 '14 at 11:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.