...before mark this as duplicated: I already tried to perform what is suggested by this and other sites, but without success:

  • create a usb live with startup disk creator / unetbootin

  • make a ext2/ext4 partition on the same device with label casper-rw

  • some suggest to remove the casper-rw file from the usb drive fat32 partition, too.

  • ...the live version will automatically use the casper-rw partition and you will see with df -h that you have 20 gb (for instance) of free space on /

I want to create a usb live device with ubuntu 14.04, then I will perform the (many) customization I need (packages installation, repository changing, many other software installations) and then using it to install on several PCs in my office. The problem is that I need more than 4gb of data to do this. I actually have ubuntu 12.04, so I did the steps suggested above with 12.04 version of startup disk creator (or with the last unetbootin version) but what I obtain is a partition called casper-rw which is mounted at boot as /media/casper-rw (or something similar), and not as /. All the suggestion I've found in internet by now are older than 14.04. Somebody has suggestions?

  • Aside from the Casper problem you are having, your plan won't work. The persistent live USB keeps two versions of default apps, the original that came with the iso and the updated one in Casper-rw. When you install from a live USB, you get the same result whether the USB is persistent or not. That is installation is done using the original, not the customized version. – user68186 Jun 17 '14 at 10:08
  • See askubuntu.com/questions/228687/… for two ways of customized installs. – user68186 Jun 17 '14 at 10:12
  • Ok I didn't know this! ...any suggestion in how to accomplish the customization task? Ubuntu builder is abandoned, what about Ubuntu Customization kit? – Fra_P Jun 17 '14 at 10:29
  • The answer you suggested is about OEM install (not my case because it is not intended to provide the same installation on different machines) and UCK (which not worked properly trying to customize 14.04 from within 12.04)... – Fra_P Jun 17 '14 at 12:16
  • Please ask a different question, after searching the forum regarding UCK. Best of luck. – user68186 Jun 17 '14 at 13:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.