0

I set up a dual boot setup on my netbook to try Ubuntu. Since I liked it, I carved out an additional partition to use with Ubuntu.

I am able to successfully mount this partion by adding this command to Startup Applications

/usr/bin/udisks --mount /dev/disk/by-uuid/c1e4fe5a-df6b-4910-811d-a6f5d76d59c2

However, in the interest of learning, I tried to mount this partition through fstab instead, since it seemed that this was the more normal way. Here are all the lines from fstab that are not comments. I added the last line.

UUID=4c24d79e-fd82-45a7-91fc-787aff8ec4e1 / ext4 errors=remount-ro 0 1

UUID=9e15e92b-411d-443e-a3d4-584748010ba5 none swap sw 0 0

UUID=c1e4fe5a-df6b-4910-811d-a6f5d76d59c2 /media/mountpoint auto auto,users,uid=1000,gid=100,dmask=027,fmask=137 0 2

Before saving the fstab, I disabled my Startup Application command, rebooted, and confirmed that the new partition was not mounted. I then saved fstab and did the

sudo mount -a

but I got this error

mount: wrong fs type, bad option, bad superblock on /dev/sda3,

  missing codepage or helper program, or other error

  In some cases useful info is found in syslog - try

  dmesg | tail  or so

I'd appreciate any advice on what I did wrong with my fstab update.

  • BTW you ONLY need to run the command to build / update fstab during something like a command line installation (archlinux for example). Just edit the file as you normally would any other file and the system will read fstab during boot on it's own. – mchid Jun 17 '14 at 4:15
1

use the line

UUID=c1e4fe5a-df6b-4910-811d-a6f5d76d59c2 /media          ext4    defaults 0       1

in /etc/fstab instead of the one you have and reboot

you don't have to do anything else; the volume will be mounted in the folder /media as the system will read fstab automatically when you boot

| improve this answer | |
  • Worked perfectly just as you wrote it. Many thanks. – Organic Marble Jun 17 '14 at 12:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.