I am using Ubuntu 14.04 with an FX-6350 processor and a EVGA GTX 750 ti SC GPU. I installed the CUDA and display drivers for the 750 ti using this tutorial: Installing and testing CUDA in Ubuntu 14.04 after restarting lightdm, it works perfectly, but upon reboot, the resolution is stuck at 640 by 480. If I log in, Unity doesn't load, just the background. I'm also using a Gigabyte motherboard. When I boot up, after POST, it shows this:

Verifying DMI Pool Data ............
error: no video mode activated
[   2.771245] nouveau E[ DEVICE][0000:01:00.0] unknown chipset, 0x117000a2
[   2.771348] nouveau E[    DRM] failed to create 0x80000080, -22
  • the current stable nvidia driver version for your video card is 337.25 I'm not sure if it's yet available in Ubuntu repos, in a link provided is 32bit version you can download 64bit as well it depends on your system. Follow the instructions in a link that you attached or in addition follow my tutorial on manually installing nvidia driver. – JoKeR Jun 16 '14 at 21:41
  • Thanks for your help. The big thing I need is CUDA, since I will be using this for cycles rendering in Blender. For my card, I need CUDA 6, but NVIDIA doesn't have an official download for 14.04 as seen here. Do you know how to install CUDA 6 on 14.04? I don't know why, when I follow the tutorial in my question, it works fine until I reboot. – user238055 Jun 17 '14 at 2:10
  • I'm going to try a fresh install of 14.04, install the driver your way, then try to install nvidia-cuda-toolkit through apt-get. – user238055 Jun 17 '14 at 2:24
  • I can't tell you much with involving CUDA6 as I'm not Nvidia representetive, this question should be addressed to Nvidia developers, one thing as I know for sure my workaround and the latest driver provided by GeForce/Nvidia should work with installation of that nvidia driver for your graphic card, I'm using myself video driver from geforce website and installed it according to that tutorial written by me. – JoKeR Jun 17 '14 at 15:31
  • 1
    possible duplicate of How to fix ubuntu load screen after install nvidia driver (331,38) – Kaz Wolfe Sep 24 '14 at 17:31

I solved this problem on your PC.
This problem xorg.conf file.

me hardware: "acer x243hd" and "gigabyte geforce gtx760"


cat xorg.conf !!!not work (640x480) this file gen nvidia-xconfig:

~$ cat /etc/X11/xorg.conf.nvidia-xconfig-original 
Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"                                                                                                           
    InputDevice    "Keyboard0" "CoreKeyboard"                                                                                          
    InputDevice    "Mouse0" "CorePointer"                                                                                              
EndSection                                                                                                                             

Section "Files"                                                                                                                        
EndSection                                                                                                                             

Section "InputDevice"                                                                                                                  
    # generated from default                                                                                                           
    Identifier     "Mouse0"                                                                                                            
    Driver         "mouse"                                                                                                             
    Option         "Protocol" "auto"                                                                                                   
    Option         "Device" "/dev/psaux"                                                                                               
    Option         "Emulate3Buttons" "no"                                                                                              
    Option         "ZAxisMapping" "4 5"                                                                                                
EndSection                                                                                                                             

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

cat xorg.conf !!!work (1920x1080):

~$ cat /etc/X11/xorg.conf
Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       30.0 - 80.0
    VertRefresh     55.0 - 75.0
    DisplaySize     400 225
    Modeline       "1920x1080_60.00"  172.80  1920 2040 2248 2576  1080 1081 1084 1118  -HSync +Vsync
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    BusID          "PCI:1:0:0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Viewport    0 0
        Depth       24
        Modes      "1920x1080_60.00"
    EndSubSection
EndSection

How get: Modeline "1920x1080_60.00" 172.80 192.... bla bla bla

~$ gtf 1920 1080 60

  # 1920x1080 @ 60.00 Hz (GTF) hsync: 67.08 kHz; pclk: 172.80 MHz
  Modeline "1920x1080_60.00"  172.80  1920 2040 2248 2576  1080 1081 1084 1118  -HSync +Vsync

add this in Section "Monitor" and do not forget to add in Section "Screen" -> SubSection "Display" string Modes "1920x1080_60.00"


To summarize:

  1. Specify the correct HorizSync and VertRefresh
  2. Gen and add you Modeline
  3. Add name Modeline in Modes

Thank you all for your attention!!!

  • I just join to community to say thank you man:) – saeed masoomi Dec 10 '17 at 10:15

see my answer here. It's because of nvidia's xorg.conf. Removing it seems to fix the issue. Execute the commands below after pressing CTRL+ALT+F1 on GDM screen or within GNOME.

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.old
sudo touch /etc/X11/xorg.conf
  • Flag as duplicate instead of answering please! – Kaz Wolfe Sep 24 '14 at 5:18
  • not much reputation mate – Steel Brain Sep 24 '14 at 13:11
  • Did it for you. Sorry, I did not realize there was a rep requirement for flags. – Kaz Wolfe Sep 24 '14 at 17:32

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.