I'm using a USB 5.1 surround sound headset and it's not working how it should.

I am able to use the 5.1 surround sound. Sometimes even in Steam games so it is possible. The problem exists when using the headset on Skype or Google Hangouts.

When I set it to "Analog Surround 5.1 Output + analog Input" in PulseAudio Volume Control I'm not able to use my mic sometimes. Usually I can but as soon as I activate my mic (by pulling it down from the side) my sound gets disabled. I need to reboot if I want sound again.

If I set it to "Digital Stereo IEC958 Output + analog Input" it works sometimes. Usually it gets set to this automatically and I hear loud static when someone talks. (Probably because it tries to send stereo into a 5.1 channel). I need to set it to 5.1 Take out the USB, kill Pulseaudio, plug it back in and set it to Digital Stereo. Only then do my sound and mic work. And this doesn't even work every time. Sometimes I need to reboot.

As you can see a whole hassle just to talk to my friends on Skype. I would love a solution for this problem. I've searched online and all I could find was checking alsamixer but it shows my headset and 5.1 channels and 2 mic inputs (just like PulseAudio).

I'm not sure what you information you need from me in order to help. Tell me and I will provide :)

  • Look into /proc/asound/cards. Is it full speed or high speed? – CL. Jun 16 '14 at 18:59
  • @CL. It's full speed. – charmesal Jun 16 '14 at 20:08
  • What headset model? Are you using a hub? – CL. Jun 16 '14 at 20:15
  • It's a CoolerMaster Sirus Storm 5.1. Model: SGH-6000-KK5R1. And I am not using a hub. I'm using a laptop btw and the problem occurs when using any of the USB ports. – charmesal Jun 17 '14 at 1:51
  • Please show the output of lsusb -v for this device. – CL. Jun 17 '14 at 7:39

This is a USB 1.x device, using full speed, i.e., 12 Mbit/s signalling. This means that the bus just has not enough bandwidth for all the channels used.

To reduce bandiwth requirements,

  • remove all other USB devices from the same bus (it is often not obvious which ports belong to the same bus),
  • reduce the sample rate to 44.1 kHz, or
  • reduce the number of playback channels to 4.
  • As long as my mic is turned off it can use all 5 channels. So just 1 extra channel is to much for the bus? – charmesal Jun 18 '14 at 0:24
  • As long as my mic is turned off it can use all 5 channels. So just 1 extra channel is to much for the bus? -There are no other USB devices connected to the bus (even if there was it has the same problem so it can handle 5.1 with a keyboard on the same bus but not with a mic) -I will try to reduce the sample rate. -Even if I set it to 4 the problem still exists. When I boot to Windows 8.1 I have no problem using it. I'm not sure what the sample rate is on Windows. I'll find out and let you know. btw The headset has a secondary usb connector but connecting it doesn't change the LSUSB -V output. – charmesal Jun 18 '14 at 0:30
  • Sorry for this late reply. Personal stuff. Apparently I do have the same problem on Windows , which is weird. Even when I set the sample rate to 44.1KHz I'm still unable to use my mic on Skype. Setting it from 5.1 channels to 4 fixes this problem on Windows and Ubuntu. I'm even able to change the sample rate back up to 48KHz. I tested it all with and without the second usb connector and there were no differences in the results. I really dislike this. I just want to be able to play a game with 5.1 surround and talk to my friends. But I guess CM wont let me. Well at least thanks for the help :). – charmesal Jun 22 '14 at 18:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.