1

I have installed the 14.04 LTS in clean. then I use wget the chrome.deb for 64 bit from Google and dpkg -i *.deb to install the chrome in my Ubuntu 14.04,however I can't launch it and get errors as below, could you please help me to solve this problem?

$ google-chrome
[2697:2697:0616/211443:ERROR:process_singleton_linux.cc(394)] readlink failed: no authority
[2697:2697:0616/211443:ERROR:process_singleton_linux.cc(240)] readlink(/home/frank/.config/google-chrome/SingletonLock) failed: no authority
[2697:2697:0616/211443:ERROR:process_singleton_linux.cc(240)] readlink(/home/frank/.config/google-chrome/SingletonLock) failed: no authority
[2697:2697:0616/211443:ERROR:process_singleton_linux.cc(264)] Failed to create /home/frank/.config/google-chrome/SingletonLock: no authority
[2697:2697:0616/211443:ERROR:process_singleton_linux.cc(394)] readlink failed: no authority
[2697:2697:0616/211443:ERROR:process_singleton_linux.cc(240)] readlink(/home/frank/.config/google-chrome/SingletonLock) failed: no authority
[2697:2697:0616/211443:ERROR:chrome_browser_main.cc(1209)] Failed to create a ProcessSingleton for your profile directory. This means that running multiple instances would start multiple browser processes rather than opening a new window in the existing process. Aborting now to avoid profile corruption.
  • why don't you try this: askubuntu.com/questions/79280/… – Raphael Jun 16 '14 at 15:08
  • I had already tried, the result is the same, still same error, don't know what's wrong. – user294082 Jun 16 '14 at 15:13
  • Try with sudo – Null pointer Jun 16 '14 at 16:37
  • Try reinstalling it. – user278630 Jun 16 '14 at 16:52
  • Delete your /home/frank/.config/google-chrome/ directory and try to start again. Worked for me... – rechengehirn Jun 16 '14 at 22:05
2

Correct the ownership, assuming frank is your username:

chown -R frank:frank /home/frank

and the permissions for all folders:

find /home/frank -type d -print0 | xargs -0 chmod 775

775 - These are the default permissions when you create a new folder.

0
  1. Open a terminal and run sudo -i nautilus

  2. Press Ctrl + H

  3. Navigate to .config/ and right click on google-chrome. Select permissions, and ensure you are the owner.

  4. Run chrome.

  • Can this damage anything? – Tim Aug 19 '15 at 15:02
0

I run 14.04 x64 and it works just fine, from the repos. I personally prefer to install programs from repos, since it's much easier to remember to update it. Delete the google-chrome you have now, and install it from Google's repos(taken from http://www.ubuntuupdates.org/ppa/google_chrome)

Setup the key with:

 wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | sudo apt-key add -

Enable the repo with:

sudo sh -c 'echo "deb http://dl.google.com/linux/chrome/deb/ stable main" >> /etc/apt/sources.list.d/google.list'

Then update the repos with:

sudo apt-get update

Then finally install Google Chrome with:

sudo apt-get install google-chrome-stable

Alternatively you could install the beta with

sudo apt-get install google-chrome-beta

Or the unstable with:

sudo apt-get install google-chrome-unstable

protected by Community Nov 21 '17 at 11:38

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.