3

I've been using eclipse (the one bundled in ADT) extensively for about a year and had no problems. But from yesterday, without any particular change (no eclipse update, no new plugins, ..., EDIT: however, I updated Firefox yesterday) it started crashing. If crashes a few seconds after I run it.

I even reset workspace, but got no success.

I was using opedjdk 7, reverted back to openjdk 6, again with no success.

Here's the console output when the crash happens:
http://pastebin.com/fT3VLkAt

And here's the more detailed error log it generates:
http://pastebin.com/UyiU8wQq

I'm using Ubuntu 14.04 in x86-64 architecture. ADT version is v22.0.1

16

Not the correct answer, but the famous workaround seems to suppress it for now:

  • Add this to eclipse.ini file:
    -Dorg.eclipse.swt.browser.DefaultType=mozilla
| improve this answer | |
  • is it working now?? – Sukupa91 Jun 16 '14 at 9:43
  • 1
    Yes, no crash for 3 hours. Before this, it was crashing 5-10 seconds after starting. – Mousa Jun 16 '14 at 9:48
  • 1
    Holy mother of workarounds! I was having the exact same issue but this seems to have fixed this!! But how does this work exactly? – Darth Coder Feb 27 '15 at 23:47
  • it does not work for me any other options? – M.Ahsen Taqi Jan 12 '17 at 13:53
  • Still works .. for some reason :) – Gajotres Mar 16 '17 at 15:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.