1

I tried to dual boot ubuntu with windows 7 and failed miserably, now I cannot get back to windows7 and my computer constantly corrupts when running Ubuntu.

I am trying to install ubuntu on my HP desktop which already has windows 7 installed. I made a bootable USB using Universal USB installer and burned the Ubuntu Desktop ISO on it.

Before I installed Ubuntu, I run the defragment program in windows 7 and then shrink the C drive which is 1.8 TB to 900GB and on the other side, I made the rest 900GB unallocated to reserver for Ubuntu /boot, / and swap.

Then I reboot the computer, plugin the USB and try to install the Ubuntu in "Something else" while selecting the installation type.

And it looks like this:

enter image description here

Some notes:

  1. All the ntfs partition are windows related partition, sda1 is probably where the bootloader goes to? sda2 is the shrinked C drive which is has 300GB usage. sda3 is where the HP recovery goes to.
  2. I tried to create the boot folder, root folder and swap space for ubuntu...

However, 9 out of 10 times, the ubuntu installation will corrupt, the screen turn pure dark, and the desktop working LED lights is on but you can not reset the machine even holding the power button... I have to unplug the power cable. Also, if you try to boot straight from the harddrive, it will go to the grub rescue mode...

Also, there is no option that I can boot back to windows...

I am so confused at why the installation will fail? (BTW, I have a GPU doesn't come with the machine and it behaved fine before I tried installing ubuntu)

Output from the bootrepair tool.


Update: using bootrepair tool to fix the error, almost no-brainer.

  • Since you are worried, have you tried the boot repair option from Windows installation DVD. For now don't mess with your system and try this first. – Raphael Jun 16 '14 at 4:26
0

Try without creating separate /boot partition.

Just create two partitions / and swap and install grub-bootloader in /dev/sda

0

It's a bit hard to achieve some conclusion here without knowing how exactly you configuredyour partition table during the first installation. Maybe the system is looking for the boot instructions in the wrong partition instead of the dedicated "/boot" one.

As the person above said, try removing your Ubuntu installation and installing your bootloader on the /dev/sda (which is the default partition).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.