KeePass2 is a Mono app. In the launcher it appears as "Untitled window" and has a grey icon with a question mark. When I "Keep in Launcher" the icon doesn't launch the application

How to fix that?


There is a bug already open for the problem you describe:



Maybe you should report this as bug for the keepass2 Ubuntu package


  • Yes I should. As a side note, I posted this question before the Ubuntu package was launched (or, at least, before I realized that it was)
    – Jader Dias
    Jun 30 '11 at 18:19

This is only a partial fix, not a solution for all problems listed.

I was able to create a launcher for it.

  1. Right click the desktop
  2. Click add launcher
  3. Give it a name "KeePass2"
  4. Tell it to execute "keepass2"
  5. Drag it to the launcher

But it still shows the "untitled window" in the launcher along the new icon.


Another partial solution:

  1. Install the new Ubuntu package

sudo apt-add-repository ppa:jtaylor/keepass

sudo apt-get update

sudo apt-get install keepass2

  1. Open the launcher and type Keepass2

  2. Drag the icon to the launcher

But it still shows the "untitled window" in the launcher along the new icon.


I fixed it on my end by calling the application without arguments. Using terminal navigate to /usr/share/applications by typing

cd /usr/share/applications 

next use your favorite text editor I like vim,

sudo vim keepass2.desktop

after this edit the line that says Exec= it should invoke the program without arguments.


save and quit which in vim happens by pressing Esc and typing wq for write quit!

Sorry for the more advanced I tried to do a step by step so everyone can follow the solution!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.