3

I downloaded Adobe Reader from here: http://get.adobe.com/reader/

By default, it recognizes my system as Linux and lets me download a .bin file which turns out to be an executable installer.

There are no installation instructions at all (shame on Adobe) but it was pretty easy to figure out I had to add execution permissions to the file and run it as root. It installed Adobe Reader under /opt.

Now I have a beautiful Adobe Reader icon on the desktop which does nothing when double clicked. NOTHING (not even an error message).

Also, if I write "Adobe" in the Dash, the same icon shows up, and it still does nothing.

By right-clicking on a pdf file's icon on the Desktop or in Nautilus, there's no "open in Adobe Reader" option either.

Is there a non-broken Adobe Reader available for Ubuntu? Where do I get it?

  • Do you have a specific reason for needing AR as opposed to something else? – Tim Jun 15 '14 at 18:09
  • Have you tried running it in wine? – Dusan Milosevic Jun 15 '14 at 18:12
  • I use evince. imo it's better and faster than adobe – answerSeeker Jun 15 '14 at 18:39
  • @Tim one reason is that evince - err I'd rather not us vulgar words. So I want to try Adobe Reader to see if it's better. – matteo Jun 15 '14 at 23:28
  • 2
    When I go to the first link above it doesn't have anything available for Linux OS. – copper.hat Jul 27 '14 at 17:49
3

As of February 2015, the only solution that worked for me is the following:

sudo add-apt-repository "deb http://archive.canonical.com/ precise partner"
sudo apt-get update
sudo apt-get install acroread

I found it here: http://ubuntuhandbook.org/index.php/2014/10/install-adobe-reader-ubuntu-14-10/

I tried all other solutions I had found by googling, and none of them worked for an updated install of Ubuntu 14.04.1.


To make it work well with Nautilus, run:

sudo -e /usr/share/applications/acroread.desktop

then fix the Exec line to Exec=acroread %u. (If the editor is nano, type Ctrl+O, <enter> to save, then Ctrl+X to exit. Finally, nautilus -q to restart.)


Important: Please test it with a fresh install of Ubuntu 14.04.1, from a newly-created user account, after installing all the updates.

| improve this answer | |
  • As of february 22, this doesn't work either. When trying to open acroread (which I have to do from the command line because, despite I chose the option to have it as the default reader for pdf, it is neither the default nor available in "open with"), I get a popup that says "an internal error occurred" – matteo Feb 22 '15 at 18:47
  • Well, it installed apparently without errors, but the fact that it wouldn't run is quite a problem :D – matteo Feb 23 '15 at 18:15
  • 1
    Maybe all the previoius attempts left something on your system. If you could test with a fresh updated install and a new user account it would be helpful. – user334639 Feb 25 '15 at 3:22
2

To install that version of Adobe I would put it in your desktop, go to the terminal, type cd Desktop; sudo chmod +x AdbeRdr9.5.5-1_i486linux_enu.bin; sudo ./AdbeRdr9.5.5-1_i486linux_enu.bin; This should start the installation process and it should finish successfully.

An easier way to install it via a software manager is:

sudo add-apt-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"
sudo apt-get update
sudo apt-get install acroread

Or you can download the deb file here: Adobe site select linux and choose deb for Ubuntu.

| improve this answer | |
  • The first method you describe is EXACTLY what I did, as I mentioned. And after "succesfully" installing it, it does not work. By running it from a terminal I figured out it complains about some missing libraries, and I found this "solution", which installs those libraries: joehalliwell.wordpress.com/2014/04/23/… Now it complains about another missing library: error while loading shared libraries: libBIB.so: cannot open shared object file: No such file or directory – matteo Jun 15 '14 at 23:34
  • Tried your second method. The first two commands seemed succesful, however the last gives: $ sudo apt-get install acroread Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package acroread – matteo Jun 15 '14 at 23:36
  • 1
    You can try downloading the actual .deb file from adobe. That should definitely work. If not I have no idea. 3rd time's a charm :) – answerSeeker Jun 15 '14 at 23:44
  • 1
    I just tried the .deb file from adobe and it worked for me. I'm using linux mint 16 which is based on ubuntu 13.10 – answerSeeker Jun 16 '14 at 2:46
  • 2
    I guess ubuntu 14.04 broke the package. Sometimes this happens when you upgrade. It works on earlier releases. – answerSeeker Jun 17 '14 at 23:49
0

An alternative, available in Ubuntu Software Center

qpdfview 0.4.7
qpdfview is a tabbed document viewer using Qt.
This version includes:
PDF support using Poppler
PS support using libspectre
DjVu support using DjVuLibre
Printing support using CUPS
See launchpad.net/qpdfview for more information

... now if this works for you might depend a bit on what you throw at it.

| improve this answer | |
  • 1
    FWIW, I use Adobe Acrobat Pro at work - it is far from bug free ;-) – Hannu Jun 18 '14 at 21:47
  • Seems a pretty good alternative!! You need to tweak its cache settings in order to handle large documents properly (by default it has a very small cache, at first i thought it didn't even have one), and I had a hard time finding out how to change the "advanced" printer settings (you have to double click on them in what looks like a non-editable list; this is Qt's fault) but once I found out, it seems to replace Evince pretty well. – matteo Jun 19 '14 at 19:48
0

Having trouble using Adobe Reader?

Why don't you install it using Ubuntu Software Center?

Installing programs in ubuntu by manually downloading files from internet is no easy feat (at least for beginners like me).

Ubuntu Software Center is the easiest way to install software in ubuntu.

| improve this answer | |
  • As mentioned in the comments to Tatakai Wasumi's answer, I tried that too, and that was broken too. Anyway, acroread for linux doesn't exist any more, so I'll forget about it. – matteo Sep 18 '14 at 20:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.