In my Ubuntu I use the Dash to be able to search my apps.

I hit super and it keep searching but no results, close the Dash, super, no results and so on until it finally starts showing results.

Sometimes, I have to restart my Ubuntu or Log out my session.

But with GNOME Shell, the search starts instantly no delays, no restarts.

How can I fix this behaviour and make my results show instantly?

I have searched AskUbuntu before posting this question.

I have tired:
unity --reset but it is deprecated!

  • Thank you. Can you help us help you by providing versions? Are you using the new gnome shell 3.8 or perhaps the tracker search extension? – Elder Geek Oct 22 '14 at 20:47

a) Is your LAN <-> WAN <-> Internet connection "slow"?
use mtr, ping and traceroute from the shell to find out - if you're using IPv6; might require other tools with similar functionality.

b) check the settings under Filter results | v

I have yet to touch these and have "Applications, Files & Folders, Music" selected for Categories | v

"Applications, Dash plugins, Files & Folders, Google Drive, Grooveshark, Rhythmbox, Songsterr, Soundcloud" selected for Sources | v.

... might be having "too many" of these selected, may be these combined with a slow network would make the effect you see.

| improve this answer | |
  • I am using the Dash for local data only. Online search results are disabled. – malhobayyeb Jun 16 '14 at 16:36

If you're only using it for local data, you may wish to disable online sources in System Settings > Privacy. Sadly, the online search results tend to slow down local searches fairly dramatically. It's intended to speed up as the system learns when you're searching for something local and when you're probably searching for something online, but in my experience, it never gets as fast as the dash was in 12.04LTS while online searches are enabled.

| improve this answer | |
  • I am using it for local data only, I have already disabled online search results. – malhobayyeb Jun 16 '14 at 16:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.