4

This question already has an answer here:

I'm having a bad time trying to install 32-bit version of Wine 1.7.19 on a 64-bit version of Ubuntu 14.04. I've got through all the questions related to that on AskUbuntu but I haven't found a working solution probably because I did a big mess with Wine (tried to compile/install it in many ways, winetricks won't work until I use ent WINE="path" winetricks, etc).
I would like to make a cleanup of everything that's related to Wine (and its components like winetricks) and perform a clean install. I tried to install Wine through the Software Center but there's only an old version of Wine, then I uninstalled it with Software Center as well. Then I used this tutorial to compile Wine: http://www.noobslab.com/2014/05/winehq-updated-to-version-1719-install.html - I compiled it in "/home/kamil/Pobrane/wine-1.7.19" but it made a 64-bit version of Wine. So basically I have two questions:

  1. How do I clean all traces of Wine to perform a clean install?
  2. How do I install/compile a 32-bit version of Wine 1.7.19?

marked as duplicate by Luis Alvarado Jun 16 '14 at 4:16

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Why do you need 32 bit wine? Can you not set 64 bit to pretend to be 32 bit? – Tim Jun 15 '14 at 12:49
  • .NET Framework 4.5 and .XNA Framework 4.0 throw errors when I try to install them, according to the link below, I need a 32-bit verison of Wine. appdb.winehq.org/… – TheReduxPL Jun 15 '14 at 12:55
  • @luis-alvarado, you marked my question as duplicate but that is not an entirely true. In the link you sent me there is indeed a description of how to use 32-bit but that didn't work with .NET and XNA frameworks. The solution that Alter Lagos gave me though, works in all aspects, installing these frameworks (and Terraria btw) didn't cause any problems. – TheReduxPL Jun 20 '14 at 12:29
  • The solution provided here is the same as the general wine answer which covers this and much more. If it worked for you i am very glad but there are several showstoppers that could happen. Good thing everything went ok with you. – Luis Alvarado Jun 20 '14 at 15:43
5

First, if you've made a mess, you could start cleaning your wine config:

rm -rf $HOME/.wine

Then add the oficial wine PPA to your sources:

sudo add-apt-repository ppa:ubuntu-wine/ppa -y && sudo apt-get update

Finally, install the 32 bits version.

sudo apt-get install wine1.8:i386
  • 1
    I'm having the following error: E: Unable to locate package wine1.7 E: Couldn't find any package by regex 'wine1.7' – mika Dec 18 '14 at 17:50
  • @mika, that's because you didn't add wine ppa – Alexander Kim Jan 2 '15 at 10:06
  • Same error as mika when trying to install on Windows Subsystem for Linux. – Tiberiu-Ionuț Stan Apr 30 '16 at 16:46
  • thanks, it worked! by the way, you can change "wine1.7:i386" to "wine1.8:i386", otherwise the error that mika mentioned above will continued (even adding wine ppa) – awdk Jul 19 '16 at 0:18

Not the answer you're looking for? Browse other questions tagged or ask your own question.