I saw many CLOSED topics about this, BUT none of proposed solutions working. When I switch to russian keyboard, shortcuts (ctrl+c, ctrl+v, ctrl+z, etc.) not working in most of applications. I have updated system 14.04. Propose the solution, but don't just close the thread saying that everything is working! Thanks in advance for any help, because I'm realy tired of this and start to think about other Linux distros.

  • Give please an example of application which does not do CTRL+Cor CTRL+V with switched Russian input on. – Ruslan Gerasimov Jun 15 '14 at 11:57
  • 1
    Inkscape - ctrl+z, ctrl+shift+z, ctrl+c, ctrl+v, ctrl+o... (all shortcuts) not working; Lazarus - only ctrl+I working, others - not; VLC - all shortcuts not working... Is there any sense to continue? – Жан Швец Jun 15 '14 at 12:43
  • 1
    Never mind, keep saying that everything works. Solved by replacing Ubuntu with another OS. Sad, but true. – Жан Швец Jun 18 '14 at 10:11
  • I am having this problem too. Ctrl-c Ctrl-v hotkeys are not working for me when Russian keyboard layout is enabled – Kirill Dubovikov Aug 6 '14 at 10:03

This worked for me

sudo add-apt-repository ppa:attente/java-non-latin-shortcuts
sudo apt-get update
sudo apt-get dist-upgrade
restart unity-settings-daemon

protected by Community Mar 23 '18 at 17:47

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.