I have a Toshiba Satellite S55-A5154 with 14.04 installed. Every time it resumes from being suspended, neither the keyboard nor mouse work. What can I do to fix this or provide you with more info?

  • reinstall or install input device drivers. sudo apt-get install xserver-xorg-input-all
    – user224082
    Commented Jun 15, 2014 at 0:36
  • sudo apt-get install --reinstall xserver-xorg-input-all did it. Thanks, 123456. Commented Jun 15, 2014 at 2:41
  • 1
    Welcome to AskUbuntu, and thanks for asking a clear, concise question. This was also a problem for me with a Dell T3610, and the --reinstall seems to have fixed it. I suspect the problem may have been due to a kernel upgrade (I am on 3.13.0-29)
    – Lambart
    Commented Jun 24, 2014 at 17:11
  • I had the mouse problem after installing 15.10 on my 2007 desktop. Tried various suggestions without luck. I "fixed" it by disabling EHCI in the BIOS. You probably don't have that option on your system (and I have no idea what the side effects might be) but this might be useful to somebody. Commented Jun 6, 2016 at 4:50

4 Answers 4


Reinstall or install input device drivers.

sudo apt-get install xserver-xorg-input-all 


sudo apt-get install --reinstall xserver-xorg-input-all
  • $ sudo apt-get install --reinstall xserver-xorg-input-all ... The following packages have unmet dependencies: unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed Depends: libcheese7 (>= 3.0.1) but it is not going to be installed E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages. $ uname -a Linux L502X 3.19.0-60-generic #67~14.04.1-Ubuntu SMP Wed May 18 17:22:23 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux`
    – user76369
    Commented Jun 8, 2016 at 1:06

I've tried all the answers on this page, but they didn't really work. I thought reinstalling xserver-xorg-input-all worked, but it didn't. I recently found this page and the freezing hasn't happened since. What you do is edit /etc/default/grub and change GRUB_CMDLINE_LINUX_DEFAULT to have the value "atkdb.reset i8042.nomux quiet splash" and then run sudo update-grub and reboot. This also works on 16.04.

  • 1
    Thanks for link you provided. As mentioned there, it didn't completely cure the issue with suspends generated when closing the lid. I also ended up with the following line in my grub config: GRUB_CMDLINE_LINUX="atkbd.reset=1 i8042.nomux=1 i8042.reset=1 i8042.nopnp=1 i8042.dumbkbd=1" Commented Mar 12, 2017 at 10:46
  • 2
    @ajeans Still working in '17 for 17.04. However, I guess you (and the guy on the mint page) actually meant GRUB_CMDLINE_LINUX_DEFAULT="atkbd.reset=1 i8042.nomux=1 i8042.reset=1 i8042.nopnp=1 i8042.dumbkbd=1" In any case, that's what I did, and it worked after nothing else had.
    – Mark
    Commented May 20, 2017 at 21:58
  • 4
    @Mark you are absolutely right, this goes into GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub. GRUB_CMDLINE_LINUXis the next line in this file, and mine is empty (on Ubuntu 16.04). Commented May 22, 2017 at 9:38
  • 1
    I can confirm that this also fixed my issue in 17.10 on Ubuntu Gnome. Note the version in the comments worked for me while the accepted answer with "quiet splash" failed to work. I'm on Dell XPS 13.
    – Steven
    Commented Nov 20, 2017 at 22:00
  • Thanks for the link. I am very happy to sat that this fixed the problem on my ebay purchase of a Toshiba Satellite now with Ubuntu 20.04. Great stuff !!!
    – NickT
    Commented Sep 2, 2022 at 10:19

In my case it had something to do with the graphics card driver and this fixed me (if you use some latest nvidia graphics card then getting the updated driver may work) --

sudo apt-get install nvidia-current-updates

  • Yep that solved my problem. Seems to be related to a DKMS module issue.
    – user76369
    Commented Jun 8, 2016 at 1:11

I've tried pretty much all fixes I could google (including the other answers to this question), but the only thing that helped was to install the hardware enablement stack:

sudo apt-get install linux-generic-lts-utopic xserver-xorg-lts-utopic \ 
     libegl1-mesa-drivers-lts-utopic xserver-xorg-video-all-lts-utopic \ 

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .