37

I have recently installed a fresh ubuntu 14.04. But the volume icon is missing.

  • I can hear all kinds of sounds (rythmbox, youtube videos,...) ...
  • I have already tried to install the package indicator-sound and is already installed and updated.
  • I can change the volume using the alsamixer command, but is not practical...

Any idea would be of great help. Thanks in advance.

  • Hey Joan, did any of the answers work? – Tim May 4 '15 at 13:39
51

Execute in terminal:

gsettings set com.canonical.indicator.sound visible true
| improve this answer | |
  • 15
    No such schema 'com.canonical.indicator.sound' – Aryeh Armon May 8 '16 at 5:25
  • 3
    I got the same warning first, and after run cmd as below first then the cmd above can be executed : sudo apt-get install ubuntu-desktop – zhihong Sep 9 '16 at 8:04
  • 2
    Do you have an idea why the icon can sometimes disappear? – Jérémy Pouyet Oct 10 '16 at 6:46
  • Also works on 16.04. – Luís de Sousa Oct 4 '17 at 7:05
36

Go to System Settings->Sound. Then disable and re-enable the checkbox "Show sound volume in the menu bar" in the bottom left corner.

enter image description here

| improve this answer | |
  • 2
    I can't see that button... I also doubt this will solve their problem, they have tried reinstalling etc... – Tim May 4 '15 at 13:39
  • In my case, this checkbox had been disabled after the upgrade from 15.04 to 15.10. So this helped me. Thank you the answer ! – jplandrain Mar 14 '16 at 7:34
18

In my case I removed and reinstalled pulseaudio because I was having issues with sound in Chrome. The solution to bring back the sound icon was the following:

  1. From Cacus' answer above,run:

    sudo apt-get install indicator-sound
    
  2. From Tomvo's answer above do:

    gsettings set com.canonical.indicator.sound visible true
    
  3. To make sure audio setting is available in control center do:

    sudo apt-get install unity-control-center
    
  4. Logout and back in.

| improve this answer | |
  • ...And the las line too! It solved my "empty" Settings problem. So two problems are solved. Now I still have to solve the soundcard-related problem - Dummy Output. I'm using Ubuntu 14.04 – Cristiana Nicolae Feb 16 '19 at 6:08
4

You can try do this command:

sudo apt-get install indicator-sound

if not show restart Ubuntu :)

| improve this answer | |
  • Thanks ! It worked ! I guess the sound icon disappeared when I uninstalled evolution from my Ubuntu... – Joan Jun 15 '14 at 16:15
  • That answer, worked but the problem rised again after computer restart. Chceking my /var/log/syslog file... I found that error: Aug 3 00:39:06 joan-desktop pulseaudio[4077]: [pulseaudio] core-util.c: Home directory not accessible: S’ha denegat el permís And finally I found the solution in this link link – Joan Aug 2 '14 at 22:48
1

If your sound, wifi and bluetooth sensor are missing and you have Linux Studio or any other Linux that has the Xfwm4 window manager follow this instructions

  1. Right-click on the top bar in any empty space and select Panel --> Add New Items

Here you have two options

  1. Select Indicator Plugin or Audio Mixer or drag and place it in the top bar and now you can see it in the top right corner

enter image description here enter image description here

Right-click on the top bar in any empty space Sound Icon now appears on the top right corner

After you have added the panels that you need you can relocate them by location right-clicking on it an select Move to relocate it.

enter image description here

| improve this answer | |
0
sudo apt-get install alsa-base* indicator-sound* libcanberra-pulse* osspd* osspd-pulseaudio* pulseaudio* pulseaudio-module-bluetooth* pulseaudio-module-x11* unity-control-center* unity-control-center-signon* webaccounts-extension-common* xul-ext-webaccounts*

see this link by Mythux See how to bring back

| improve this answer | |
0

Changing the icon theme often makes icons visible. But this may change your system appearance drastically.

| improve this answer | |
  • in 15.10, different themes hide the icon on my desktop. I installed "unity-tweak-tool". Used the tool to select the Radiance theme with gnome-colours-common icons. voila. sound icon reappeared. – rob grune Jan 13 '16 at 12:55
  • I understand that the themes may hide icons and text (I have a problem with Ubuntu Software Center but...) the question was answered correctly in June 2014 - the OP never marked this post as having been correctly answered. – Charles Green Jan 16 '16 at 16:23
0

For me, as a matter of record for others,

right-click on the top menu bar select "Add to Panel" select "Indicator Applet Complete" from the list click "Add", the close

Now the Volume Control is up there.

JohnJoe

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.