1

The compose key was working fine for me using the US keyboard with Italian characters key mapping. It worked in LightDM and it worked in Gnome. I would press RALT-E and I would get è.

Then recently it changed. LightDM still works, but when in Gnome it became two key strokes: RALT-~E. then a few days ago, one of my user IDs decided to stop working entirely. Compose key behaves like a normal ALT key. But only in one user ID; my other user ID still works.

  • I have XKBOPTIONS="compose:ralt" in /etc/default/keyboard. (I think that's why LightDM works.)
  • I went to the keyboard settings and tried to set the compose key. I noticed it had been set to disabled, but setting it to any key does nothing.
  • In the dconf editor I have org.gnome.desktop.input-sources set to ['compose:ralt'].

What else should I look at? what files, including in $HOME, does Gnome use to determine compose key behavior??

Thanks!

1

Hours later figured out why the compose key was ignored for the one user. Still don't know why it went from one keystroke to two, but the inability to use it at all was my main reason for posting this question.

dconf had an override value for /org/gnome/settings-daemon/peripherals/numlock-state. Resetting this made compose key work. Why that matters is a mystery to me!! But somehow it magically fixed the problem.

Brought back unpleasant memories of the evil Windows system registry and regedit. sigh

0

After rebooting a Xubuntu system (Ubuntu 15.10, kernel upgraded to 4.2.0-30-generic) I tripped over (almost) the same problem. Similar like you, I had set up XKBOPTIONS="compose:caps" in the file /etc/default/keyboard to enable the compose key globally. This worked for all users except one, even in console mode.

I checked the files ${HOME}/.config/xfce4/xfconf/xfce-perchannel-xml/keyboard-layout.xml (which are updated by Settings → Keyboard → Layout). One user who had never changed his layout had no such file. Another user with a working compose-key had a “reasonable” setup. Therefore I tried to copy this setup to the problematic user to no avail. Neither did it help to remove the file. Even rebooting did not solve the problem. Finally, the solution was to invoke

setxkbmap

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.