When I try to convert a video - specifically, a Video Object (".vob") file - to MPEG-4, WinFF which I assume is a frontend for ffmpeg and avconv, but it tells me:

`Unknown encoder 'libvo_aacenc'`

The full text from Terminal is:

avconv version 9.13-6:9.13-0ubuntu0.14.04.1, Copyright (c) 2000-2014 the Libav developers
built on May  9 2014 13:34:03 with gcc 4.8 (Ubuntu 4.8.2-19ubuntu1)
[mpeg @ 0x1924160] max_analyze_duration reached
Input #0, mpeg, from '/media/gregoryopera/Movies/Get a Horse!.vob':
 Duration: 00:00:04.37, start: 0.221156, bitrate: 631225 kb/s
Stream #0.0[0x1e0]: Video: mpeg2video (Main), yuv420p, 720x576 [PAR 64:45 DAR 16:9], 9800 kb/s, 25 fps, 25 tbr, 90k tbn, 50 tbc
Stream #0.1[0x20]: Subtitle: dvdsub
Stream #0.2[0x21]: Subtitle: dvdsub
Stream #0.3[0x22]: Subtitle: dvdsub
Stream #0.4[0x23]: Subtitle: dvdsub
Stream #0.5[0x24]: Subtitle: dvdsub
Stream #0.6[0x25]: Subtitle: dvdsub
Stream #0.7[0x26]: Subtitle: dvdsub
Stream #0.8[0x27]: Subtitle: dvdsub
Stream #0.9[0x28]: Subtitle: dvdsub
Stream #0.10[0x29]: Subtitle: dvdsub
Stream #0.11[0x2a]: Subtitle: dvdsub
Stream #0.12[0x2b]: Subtitle: dvdsub
Stream #0.13[0x80]: Audio: ac3, 48000 Hz, 5.1, fltp, 384 kb/s
Stream #0.14[0x81]: Audio: ac3, 48000 Hz, stereo, fltp, 192 kb/s
Stream #0.15[0x82]: Audio: ac3, 48000 Hz, 5.1, fltp, 384 kb/s
Stream #0.16[0x83]: Audio: ac3, 48000 Hz, 5.1, fltp, 384 kb/s
Stream #0.17[0x84]: Audio: ac3, 48000 Hz, 5.1, fltp, 384 kb/s
Unknown encoder 'libvo_aacenc'
Press Enter to Continue*

When I press "Enter", Terminal closes and my conversion is canceled.

And before anyone says it - I did find the other answer relating to this same question here on Ask Ubuntu... However that guy compiled it from scratch, which I do not want to do (for a start, I wouldn't know where to begin!)...

  • 1
    I have the same problem. But libvo-aacenc0 is already installed. – user319205 Aug 21 '14 at 19:47

I confirm with vinay, but you must modify a command line to this:

sudo apt-get install libavcodec-extra

P.S. Edited command.

sudo apt-get install libavcodec-extra-54 

Based on this instant of this video

libvo_aacenc was low quality and FFmpeg removed support for this encoder.

Use -c:a aac or -c:a libfdk_aac instead.

See FFmpeg Wiki: AAC for more info.

Install the visualon AAC encoder library

sudo apt-get install libvo-aacenc0

I had luck with:

sudo apt-get install libvo-aacenc-dev

Well, I'm not much of an expert, but this worked for me:

when I entered the files I wanted to convert, I took a look at the options. In the "ffmpeg" tab there was this code... I just replaced the "libvo_aacenc" with "libfdk_aac", started the converting and it worked... maybe someone more into this can explain what exactly happened... :)

protected by Community Dec 18 '14 at 22:44

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.