1

Using Ubuntu 14.04 When I plug external speakers into the pro docking station with my Thinkpad T440p in it I get no sound (internal speakers mute).

Plugging the same speakers into the headphone jack on the laptop works fine

The following solution I found several places online but it did not work after restarting my machine.

Added the line

options snd-hda-intel model=thinkpad

to the /etc/modprobe.d/alsa-base.conf

After that didn't work I upgraded to a newer kernel 3.14.1-031401-generic, that worked to enable HDMI sound but the sound on the docking station still does not work.

0

I also had the same problem: output via laptop sound jack fine, but nothing via dock sound jack. After trying the above and several others hints, I found this description in Thinkwiki, which says that it is a bug still present in older kernels such as the one in Ubuntu 14.04. It also gives a link to this workaround. That worked for me!
Watch out for the "magic numbers", the one for T440p is given at the end of the comment 11 and it should replace the one in the [codec] part. I did not dare creating the files using cat, so I created them using gedit and then copied them to the correct locations with sudo cp.

This is the final solution - create 2 new files:
/lib/firmware/t440p_myname.fw   (you can name it whatever you like, but refer to that name in the 2nd file):

[codec]
0x10ec0292 0x17aa220e 0

[pincfg]
0x16 0x21211010
0x19 0x21a11010

/etc/modprobe.d/hda-intel.conf:

options snd-hda-intel patch=t440p_myname.fw,t440p_myname.fw,t440p_myname.fw

After a reboot, sound worked from the docking station jack.

1
  • Do you happen to know where to find such "magic numbers" for combo Dell XPS 15 9500 and dock Dell WD19? – Tomasz Kapłoński Apr 7 at 5:46
0

This post helped me with the same issue.

Or maybe you try this setting:

options snd-hda-intel model=lenovo-dock
1
  • Thanks for giving this a try. Unfortunately it didn't work. I added that line to /etc/modprobe.d/alsa-base.conf then I saved the file and restarted but I still have the same problem. – dewet Sep 23 '14 at 17:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.