I have Ubuntu 14.04 on my MacBook Pro Retina MacBookPro10,2 and the microphone does not work at all.

It has worked in 13.04 and 13.10 but now after a clean install, no luck.

I ran this script to get some more info

wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh

which uploaded the info to http://www.alsa-project.org/db/?f=140db56ebf8372fc1ee6026a8164c610264d8165

I'm not sure what I'm looking for though.

I've tried reinstalling ALSA and also installing PulseAudio with no luck.

The speakers are working just fine.

Here is a screenshot of alsamixer. I've tried switching to Internal Mic 1 with no luck.


I'm looking forward to any help. I'm really struggling without a microphone as I work from home and do a lot of VoIP calls.


Well I finally found it. Amazing how quickly that happens after you ask a question.

I added the following line to /etc/modprobe.d/alsa-base.conf

options snd-hda-intel model=mbp101

Credit goes to fooblahblah https://bbs.archlinux.org/viewtopic.php?id=144255&p=4

So happy right now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.