I installed Xubuntu 14.04 amd64 on the computer at the computer repair shop where I work, but the screen resolution is way low, like 1024 x 768 (that wouldn't be low for a laptop or anything, but for a large desktop screen it is) I went to the display settings, but the resolution wouldn't go higher than that.

When I installed Xubuntu 14.04 i386 at my computer at home, I didn't have any problems with the resolution. Any help?

Update: I ran lspci | grep VGA and got:

00:0d.0 VGA compatible controller: NVIDIA Corporation C61 [GeForce 6150SE nForce 430] (rev a2)

1 Answer 1


I had a similar problem after installing proprietary drivers for my ATI Mobility Radeon 4570 HD. It was the same with fglrx, fglrx-updates, fglrx-amdcce and fglrx-amdcce-updates. Removing all of them, resultion came back as before. It should be noted that they are in conflict, so only one package at time should be installed. I tried to do so, but the problem persisted. Remove all of them turned into the best solution for me. Hope this could help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.