17

I want to learn Vim. The vast majority of people advise me to use vimtutor. I downloaded the package and ran it, but I just get given a blank screen.

enter image description here

I see on Youtube that there should be tons of things on there. But I am not getting it...How can I fix this?

Originally, I was told by the terminal to install vim-runtime in order to run vimtutor, and I did and it ran, albeit with a blank screen. I was able to run this tutorial after I installed vim-gtk. Anyone know why it didn't show up the first time?

6
  • 2
    It is sort of a long-standing problem see bugs.launchpad.net/ubuntu/+source/vim/+bug/255847 Try installing vim (and removing vim-tiny). You may also need to log out and back in for some of your environmental variable to be updated.
    – Panther
    Jun 12, 2014 at 15:26
  • Thank you for the link. I fixed it by installing vim-gtk, it was very frustrating though...thanks again for your comment.
    – dayuloli
    Jun 12, 2014 at 15:32
  • @dayuloli can you post the solution that worked for you as an answer and accept it so this question is no longer listed as unanswered? Jun 17, 2014 at 17:21
  • @mtmiller I have instead posted the solution that resolved the issue in the question itself, but I still do not know the reason for why it happened. So I will leave it open for now.
    – dayuloli
    Jun 19, 2014 at 11:31
  • @dayuloli before you installed vim-gtk, what vim* packages did you have installed? Did you only have the vim-tiny variant installed? Jun 19, 2014 at 14:45

2 Answers 2

20

The vimtutor command requires a Vim that has Vim scripting support compiled in. For those familiar with building Vim from source, this requires at least the normal feature set or higher.

The default Ubuntu desktop installation only includes the vim-tiny Install vim-tiny package, which is Vim compiled with almost all optional features disabled. This variant of Vim provides enough to run vi with all of the basic functionality of a vi-compatible editor, but none of the power of Vim. Since it does not have Vim scripting support enabled, it cannot work with the vimtutor command. You should install one of the more capable Vim variant packages instead:

Any one of these packages provide a Vim that is capable of running vimtutor. For more about the differences between these Vim variants, see the following questions:

3

You need to install vim before using vimtutor!

Run the following command in the Terminal prompt!

sudo apt install vim

Now use vimtutor for learning. Happy Learning!

1
  • 2
    This solution worked for me and was more immediately useful than the accepted solution. Granted, the accepted solution explained the problem better.
    – Mike Lyons
    Aug 12, 2020 at 21:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .