2

I setup Ubuntu 14.04 MAAS on one server. I setup interface to manage DHCP and DNS via the Cluster interface. DHCP is working. But, DNS is not!

When I try to add another node, it is doing PXE boot, getting IP address from the cluster controller, and booting up...But, it is not connected to internet - "ping google.com" does not work.

I have two interfaces on MAAS server. One interface connected to our organization network. And, another interface for managing private network - all the nodes for the cluster. The latter interface is where I have my own DHCP Server.

My DHCPD.Conf option domain-name-servers <>; I even tried setting it to option domain-name-servers <>;

Any suggestions on how I can fix the above?

Thanks

  • Following error appears: failed [3/6] (00-maas-03-install-lldpd, 99-maas-01-wait-for-lldpd, 99-maas-02-capture-lldp) - I referenced ideasnet.wordpress.com/category/… and changed /etc/squid-deb-proxy/allowed-networks-src.acl to include private network...still problem....any suggestions? – user1680784 Jun 19 '14 at 14:45
  • I remember something about making your DNS server have an upstream source, so that it knows where to go when its clients ask for things it doesn't know. I have now given you more information than I have. – rmustakos Jul 7 '15 at 18:21
  • Set upstream DNS Open http://<maas-server-ip>/MAAS/settings/ in a browser. Look for "Upstream DNS used to resolve domains not managed by this MAAS" and set the DNS to something like 8.8.8.8 [whatever your upstream dns server is] – rmustakos Jul 7 '15 at 18:41

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.