2

Ubuntu 12.04 LTS.

For information:

  1. Autostart works, and Dropbox is active item in Startup Applications.
  2. libappindicator1 is installed
  3. nautilus-dropbox reinstalled several times
  4. dropbox works, icon is visible only when started manually.
  5. No tray whitelist manipulation is done, and no is wanted because whitelisted dropbox provides menu which does not have unity theme.
  6. The wrong behavior started after about 3 months of correct starting, so there had to be something what trigered the wrong behavior.

After login:

In Unity ... dropbox icon is missing. But dropbox is running and aparently works.

ps -u `whoami` | grep dropbox
3433 ?        00:00:03 dropbox

Manual restart in terminal

dropbox stop;dropbox start
Dropbox daemon stopped.
Starting Dropbox...Done!

... Now Unity panel shows the icon, the menu has unity theme. The same correct behavior if I run dropbox.desktop by clicking in ~/.config/autostart (after setting executable bit).

Why Unity prevents Dropbox icon to show after autostart startup and does not prevent it when run by hand? Is it some timing during session init?

The dropbox entry in Startup Applications (autostart) was inserted via "dropbox autostart". All is done by proper installation.

I must do "dropbox stop;dropbox start" after login to show the icon in tray.

Post answer note:

At last, after having used the WAR suggested in answer, I found on another computer with the same problem that the cause (or one of causes) was xfce desktop. After full removal of xfce desktop, the Dropbox icon started to be visible again.

  • Also encountering this on Cinnamon, so definitely not an Unity-only thing. – pileofrocks Mar 7 '15 at 5:48
1

I think dropbox fires up earlier than unity. Make a costum launcher in startup applications like

sh -c "sleep 45 && dropbox start -i"

It should work

  • Yes, DIY launcher works. It is good workaround. I removed the launcher installed by dropbox and disabled start at system startup in dropbox preferences. Then I inserted new launcher by hand, as you specified. – Petr Matousu Jun 29 '14 at 15:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.