0

I attempted to load Windows 8 and Ubuntu alongside each other and it was working well until my Ubuntu installation completed and I restarted the computer. Now I can't get past this error:

Minimal bash-like line editing is supported.
For the first word, TAB lists possible command completions.
Anywhere else TAB lists possible device or file completions.
Grub>

How do I fix this? I'm not a computer person. Talk me through it. I'm using GNU GRUB version 2.02 beta 2-9.

0
0

If your goal is to fix Windows, this may help you, or at the very least it will save someone else about 6 hours of googling:

I had the same problem after trying to dual-boot Windows 8 and Ubuntu 14.04 then deleting the Ubuntu partitions. I tried using the usual bootrec /fixmbr, /fixboot, etc.

None of this worked. The problem is that you have to first move to the EFI partition, rename the BCD file, then run the bootrec /fixmbr, bootrec /fixboot, and bootrec /rebuildbcd commands.

See this tutorial: http://www.fixedbyvonnie.com/2013/12/how-to-repair-the-efi-bootloader-in-windows-8/#.VAQWdDJdU4o

Then after step 3:

Enter: bootrec /fixmbr [Press Enter]
Enter: bootrec /fixboot [Press Enter]
Enter: bootrec /rebuildbcd [Press Enter]

It will ask you which installations you want to rebuild the BCD file for. I just entered All. Then I restarted and all was back to normal. Hope that helps.

3
  • Erm, this is Ask Ubuntu... If you want to give Windows answers, better to to superuser.com... (this answer is off-topic here)
    – Fabby
    Jul 15 '15 at 18:56
  • I'll politely disagree. The question asks for a solution to a very specific problem resulting from dual-booting Windows and Ubuntu. The answer explains how to fix/recover from this problem. Jul 15 '15 at 20:06
  • Sorry, I've put it up for a vote already whether it is on-topic or not...
    – Fabby
    Jul 15 '15 at 20:09

Not the answer you're looking for? Browse other questions tagged or ask your own question.