3

I've recently installed ubuntu and I need Android SDK (and subsequently, adb) in order to develop my apps to college. The fact is that, no matter what I do, I can't get adb to work. Exporting its place to the PATH didn't worked. I only get "file or directory not found" error while this are the contents of the PATH variable:

renan@RocketQueen:~$ echo $PATH
/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/home/renan/adt/sdk/tools:/home/renan/adt/sdk/platform-tools

I don't want to install android-tools-adb/fastboot because they're outdate when compared to SDK Manager ones. What do I need to do in order for it to work from anywhere when called from terminal?

  • If adb is at /home/renan/adt/sdk/platform-tools and your exported path is the one above, then it should run by just typing adb in the terminal – hytromo Jun 12 '14 at 2:20
  • the matter is that adb is there, but I still get the file not found error – Renan Lazarotto Jun 12 '14 at 2:33
  • If you really want just a quick solution, make a symbolic link to /usr/bin/adb of the adb executable – hytromo Jun 12 '14 at 2:36
  • gave me the same error. do I need to remove the exported path first? renan@RocketQueen:~$ sudo ln -s /home/renan/adt/sdk/platform-tools/adb /usr/bin/adb [sudo] password for renan: renan@RocketQueen:~$ adb bash: /usr/bin/adb: Arquivo ou diretório não encontrado renan@RocketQueen:~$ – Renan Lazarotto Jun 12 '14 at 2:52
  • Is your platform 32-bit or 64-bit? What is the output of ldd $(which adb) – steeldriver Jun 12 '14 at 3:15
2
sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install libc6:i386 libncurses5:i386 libstdc++6:i386
cd /home/renan/adt/sdk/platform-tools
./adb

if you get an error you may need to run

sudo ./adb

instead

Source:

http://www.gaggl.com/2014/05/android-sdk-issues-on-ubuntu-14_04_64bit/

For full multiarch support you can run

sudo apt-get dist-upgrade

(after adding the i386 arch and running apt-get update of course)

http://www.unixmen.com/enable-32-bit-support-64-bit-ubuntu-13-10-greater/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.