I was able to listen with my BT headset, but suddenly, one day, it disappeared from sound settings forever!

I've even re-paired my headset (and its connected already) but it doesn't have any options in sound settings in order to listen from it.

When I try this command:

hcitool scan

It doesn't find any devices! Even this command:

pactl list cards short

Only lists my default sound card only! What should I do?

  • Not an answer to this question, but I found this question when searching for my problem and maybe my comment helps others aswell; I saw my bluetooth sink in pactl list short sinks and was unable to play music with it. Disconnecting via bluetoothctl and requesting the default agent (thus typing bluetoothctl, then disconnect, then default-agent, and then connect [device]) helped me. Commented Oct 4, 2023 at 9:37
  • I had this issue just now with a fresh Ubuntu 22.04 and new Sony buds, and the solution for me was... try repairing a third time. Didn't show up in sound settings the first two times, but did on the third. No idea why.
    – joe
    Commented Feb 18 at 5:14
  • This is still happening in 2024.
    – Kingsley
    Commented May 15 at 20:18

7 Answers 7


Extending upon Mark's answer, which basically did the trick for me.

The problem is that the bluetooth service tries to load the pulseaudio bluetooth module at startup, which fails because they require X11 to be running. You need to change the configuration so that the pulseaudio bluetooth module is loaded after X11.

  1. Tell the bluetooth service to not load the module. To do this, edit /etc/pulse/default.pa and comment out these lines by putting # characters in front of them:

    .ifexists module-bluetooth-discover.so
    load-module module-bluetooth-discover
  2. Configure the module to be loaded after X11. To do this, edit /usr/bin/start-pulseaudio-x11 and add two lines:

    if [ x"$DISPLAY" != x ] ; then
        # ...
        # Add these lines:
        /usr/bin/pactl load-module module-bluetooth-discover
        /usr/bin/pactl load-module module-switch-on-connect
  3. Restart pulseaudio and bluetooh. Either reboot your machine or use the following commands:

    pulseaudio -k
    sudo service bluetooth restart

This way, the pulseaudio bluetooth module should be working and Volume Control (pavucontrol) should detect the bluetooth device and list it under input and output devices.

  • 6
    I'm voting up but all I needed was to sudo service bluetooth restart
    – wranvaud
    Commented Mar 11, 2019 at 23:40
  • Thanks, this worked for me after a full system reboot (restarting the service didn't work. I am on Arch linux and all was well until I did a full system update last week. The only thing that isn't working is the output selector in the top right of Gnome, it doesn't show multiple outputs, just one. So I have to open sound settings to choose it, but at least it is in the list now. Commented Jul 16, 2020 at 16:47
  • This does not work in Ubuntu 20.04
    – con
    Commented Nov 1, 2020 at 2:12
  • The three commands of step 3. saved me a reboot on Ubuntu 20.04.
    – Ben Mares
    Commented Feb 8, 2022 at 14:36

Try this command:

sudo -H pactl load-module module-bluetooth-discover

I run this whenever I have paired, and successfully connected, but still can't see them in sound settings. It essentially tells pulseaudio to load reload it's list of bluetooth devices.

  • 14
    Why was this answer accepted? What caused the problem to begin with, and what's the long-term fix? Ubuntu bluetooth worked perfectly for me, and then after a power outage it stopping working entirely. This command fixes it, but having to manually run this command every time I want to use bluetooth is not a solution. I've downvoted this answer until more explanation is provided.
    – Cerin
    Commented Sep 5, 2014 at 18:18
  • 3
    I'm having this same problem on Ubuntu 14.04. However, this solution did not work for me. Commented Sep 13, 2014 at 3:00
  • 33
    I am getting this error: "Failure: Module initialization failed". Can anybody help?
    – Jay Chakra
    Commented May 7, 2016 at 20:03
  • 11
    I get the following error: No protocol specified xcb_connection_has_error() returned true Connection failure: Connection refused pa_context_connect() failed: Connection refused
    – Startec
    Commented Apr 28, 2018 at 7:27
  • 9
    I'm getting "Connection failure: Connection refused pa_context_connect() failed: Connection refused "
    – Gal Bracha
    Commented Dec 13, 2021 at 13:18

I had the same problem on Ubuntu 20.04 with my Pixus Bluetooth headphones. The ubuntu Bluetooth manager saw the headphones and correctly connected them, but ALSA didn't see them.

You can check the list of Bluetooth devices by command

bluetoothctl devices

and you can check what outputs ALSA has by command

pactl list sinks short

The solution that I found is to set option ControllerMode to bredr in file /etc/bluetooth/main.conf

# Restricts all controllers to the specified transport. Default value
# is "dual", i.e. both BR/EDR and LE enabled (when supported by the HW).
# Possible values: "dual", "bredr", "le"
#ControllerMode = dual
ControllerMode = bredr

When you changed the option restart Bluetooth service

sudo gedit /etc/bluetooth/main.conf
sudo systemctl restart bluetooth

Then connect headphones again and check that ALSA sees it. If so then it must be shown as the available output in ubuntu sound settings

pactl list sinks short
enter code here
  • 1
    Also, I still have some problems. When my headphones automatically connected, I don't see them in sound settings. but if I reconnect them in settings manually then they appear in sound settings. Commented Dec 29, 2020 at 13:22
  • Works for me also in Debian 10
    – restrepo
    Commented Jun 9, 2021 at 17:00
  • It was enough just to restart bluetooth module with sudo systemctl restart bluetooth Commented Jan 11, 2022 at 7:22
  • This was the only answer which worked for me with the same problem on Ubuntu 22.04 and a pair of Sony WH-1000XM4.
    – droid001
    Commented Jan 1, 2023 at 11:09
  • Can't believe this worked. I was so skeptical after having tried different things and it seems surprising that "dual" is wrong.
    – Kvothe
    Commented Nov 28, 2023 at 16:59

The headset is properly paired and shows under Bluetooth Devices but it does not show as an available INPUT / OUTPUT source for audio. The problem is that the pulseaudio bluetooth module is loaded before X11, changing a couple of config files do the trick:

PulseAudio can not load bluetooth module 15.10/16.04

nano /etc/pulse/default.pa

Comment out the following lines:

#.ifexists module-bluetooth-discover.so
#load-module module-bluetooth-discover

nano /usr/bin/start-pulseaudio-x11

Find the following lines and add after them:

if [ x”$SESSION_MANAGER” != x ] ; then
/usr/bin/pactl load-module module-x11-xsmp “display=$DISPLAY session_manager=$SESSION_MANAGER” > /dev/null
Add the following lines:
/usr/bin/pactl load-module module-bluetooth-discover
/usr/bin/pactl load-module module-switch-on-connect

This way the Pulse audio’s Bluetooth modules will not be downloaded at boot time but after x11 is started.

  • 4
    Is there some service that needs to be restarted for these changes to take effect? Commented Nov 8, 2017 at 5:01
  • You can trigger them on the command line as in the answer above .... my post is how to have it automate on startup.
    – Mark
    Commented Mar 27, 2019 at 23:49
  • I think you're saying that if you type the three /usr/bin/pactl commands at the command line, they'll take effect immediately. It also looks like the two to add to /usr/bin/start-pulseaudio-x11 should be inside the if statement. Can you confirm both of these observations? Thanks! Commented Apr 12, 2019 at 23:01
  • 1
    The lines are inserted after the shown if..fi but within the larger if [ x"$DISPLAY"...fi. Yes, you should be able to execute the commands directly in terminal.
    – Mark
    Commented Apr 13, 2019 at 10:39

I am not able to comment on the top response, but I thought I'd add that on my Ubuntu MATE 12.04 LTS Laptop, I had to do:

sudo apt-get install pulseaudio-module-bluetooth

only then did this work

sudo -i pactl load-module module-bluetooth-discover

Then I had to go into bluetooth manager app, pair the device, then set to 'Audio Sink' mode, then I could see the device within the Ubuntu Sound options and manipulate inputs/outputs!


The permanent solution would be to add the blueman PPA and update your package to the latest version which has the bug fixed: https://launchpad.net/~blueman/+archive/ubuntu/ppa

sudo add-apt-repository ppa:blueman/ppa
sudo apt-get update
sudo apt-get upgrade

That way, you should no longer have to run the

sudo -i pactl load-module module-bluetooth-discover

command every time but only once. Works for me on 14.04 LTS (Trusty)


  • This does not apply for 16.04. The repository has no release candidate for it.
    – k0pernikus
    Commented Jan 6, 2017 at 14:57
  • @k0pernikus Seems like you can just sudo apt install blueman directly in 16.04: askubuntu.com/questions/764273/…
    – Andrew Mao
    Commented Dec 11, 2017 at 19:28

In Ubuntu 23.10 disabling wireplumper did it: $ systemctl --user disable --now wireplumber

You must log in to answer this question.