57

I was able to listen with my BT headset, but suddenly, one day, it disappeared from sound settings forever!

I've even re-paired my headset (and its connected already) but it doesn't have any options in sound settings in order to listen from it.

When I try this command:

hcitool scan

It doesn't find any devices! Even this command:

pactl list cards short

Only lists my default sound card only! What should I do?

6 Answers 6

30

Try this command:

sudo -H pactl load-module module-bluetooth-discover

I run this whenever I have paired, and successfully connected, but still can't see them in sound settings. It essentially tells pulseaudio to load reload it's list of bluetooth devices.

23
  • 4
    You might consider adding a little more context -- people just seeing this command probably have little idea what it does, whether it's sketchy, whether it needs to be repeated on reboots, etc..
    – belacqua
    Jun 11, 2014 at 20:34
  • 13
    Why was this answer accepted? What caused the problem to begin with, and what's the long-term fix? Ubuntu bluetooth worked perfectly for me, and then after a power outage it stopping working entirely. This command fixes it, but having to manually run this command every time I want to use bluetooth is not a solution. I've downvoted this answer until more explanation is provided.
    – Cerin
    Sep 5, 2014 at 18:18
  • 3
    I'm having this same problem on Ubuntu 14.04. However, this solution did not work for me. Sep 13, 2014 at 3:00
  • 29
    I am getting this error: "Failure: Module initialization failed". Can anybody help?
    – Jay Chakra
    May 7, 2016 at 20:03
  • 3
    @BhikkhuSubhuti the last update to that repository was 90 weeks ago - nearly 2 years. That is not a solution for 16.04 - in fact it hasn't worked since 15.04.
    – Tim
    Dec 28, 2016 at 0:35
22

Extending upon Mark's answer, which basically did the trick for me.

The problem is that the bluetooth service tries to load the pulseaudio bluetooth module at startup, which fails because they require X11 to be running. You need to change the configuration so that the pulseaudio bluetooth module is loaded after X11.

  1. Tell the bluetooth service to not load the module. To do this, edit /etc/pulse/default.pa and comment out these lines by putting # characters in front of them:

    .ifexists module-bluetooth-discover.so
    load-module module-bluetooth-discover
    .endif
    
  2. Configure the module to be loaded after X11. To do this, edit /usr/bin/start-pulseaudio-x11 and add two lines:

    if [ x"$DISPLAY" != x ] ; then
        # ...
    
        # Add these lines:
        /usr/bin/pactl load-module module-bluetooth-discover
        /usr/bin/pactl load-module module-switch-on-connect
    fi
    
  3. Restart pulseaudio and bluetooh. Either reboot your machine or use the following commands:

    pulseaudio -k
    start-pulseaudio-x11
    sudo service bluetooth restart
    

This way, the pulseaudio bluetooth module should be working and Volume Control (pavucontrol) should detect the bluetooth device and list it under input and output devices.

7
  • 1
    The above doesn't work for me; instead, I get start-pulseaudio-x11 /usr/bin/start-pulseaudio-x11: 24: /usr/bin/start-pulseaudio-x11: /usr/bin/pact1: not found Apr 18, 2018 at 18:10
  • 2
    @user1945827 : it's "pactl", not "pact1". It stands for PulseAudio Control. May 2, 2018 at 19:44
  • 1
    @static_rtti thanks. I managed to get it working. May 3, 2018 at 13:34
  • 2
    I'm voting up but all I needed was to sudo service bluetooth restart
    – wranvaud
    Mar 11, 2019 at 23:40
  • Thanks, this worked for me after a full system reboot (restarting the service didn't work. I am on Arch linux and all was well until I did a full system update last week. The only thing that isn't working is the output selector in the top right of Gnome, it doesn't show multiple outputs, just one. So I have to open sound settings to choose it, but at least it is in the list now. Jul 16, 2020 at 16:47
14

The headset is properly paired and shows under Bluetooth Devices but it does not show as an available INPUT / OUTPUT source for audio. The problem is that the pulseaudio bluetooth module is loaded before X11, changing a couple of config files do the trick:

PulseAudio can not load bluetooth module 15.10/16.04

nano /etc/pulse/default.pa

Comment out the following lines:

#.ifexists module-bluetooth-discover.so
#load-module module-bluetooth-discover
#.endif

nano /usr/bin/start-pulseaudio-x11

Find the following lines and add after them:

if [ x”$SESSION_MANAGER” != x ] ; then
/usr/bin/pactl load-module module-x11-xsmp “display=$DISPLAY session_manager=$SESSION_MANAGER” > /dev/null
fi
Add the following lines:
/usr/bin/pactl load-module module-bluetooth-discover
/usr/bin/pactl load-module module-switch-on-connect

This way the Pulse audio’s Bluetooth modules will not be downloaded at boot time but after x11 is started.

4
  • 4
    Is there some service that needs to be restarted for these changes to take effect? Nov 8, 2017 at 5:01
  • You can trigger them on the command line as in the answer above .... my post is how to have it automate on startup.
    – Mark
    Mar 27, 2019 at 23:49
  • I think you're saying that if you type the three /usr/bin/pactl commands at the command line, they'll take effect immediately. It also looks like the two to add to /usr/bin/start-pulseaudio-x11 should be inside the if statement. Can you confirm both of these observations? Thanks! Apr 12, 2019 at 23:01
  • 1
    The lines are inserted after the shown if..fi but within the larger if [ x"$DISPLAY"...fi. Yes, you should be able to execute the commands directly in terminal.
    – Mark
    Apr 13, 2019 at 10:39
12

I had the same problem on Ubuntu 20.04 with my Pixus Bluetooth headphones. The ubuntu Bluetooth manager saw the headphones and correctly connected them, but ALSA didn't see them.

You can check the list of Bluetooth devices by command

bluetoothctl devices

and you can check what outputs ALSA has by command

pactl list sinks short

The solution that I found is to set option ControllerMode to bredr in file /etc/bluetooth/main.conf

# Restricts all controllers to the specified transport. Default value
# is "dual", i.e. both BR/EDR and LE enabled (when supported by the HW).
# Possible values: "dual", "bredr", "le"
#ControllerMode = dual
ControllerMode = bredr

When you changed the option restart Bluetooth service

sudo gedit /etc/bluetooth/main.conf
sudo systemctl restart bluetooth

Then connect headphones again and check that ALSA sees it. If so then it must be shown as the available output in ubuntu sound settings

pactl list sinks short
enter code here
5
  • 1
    This is the only solution that worked for me. Thanks! Dec 28, 2020 at 16:05
  • Also, I still have some problems. When my headphones automatically connected, I don't see them in sound settings. but if I reconnect them in settings manually then they appear in sound settings. Dec 29, 2020 at 13:22
  • Works for me also in Debian 10
    – restrepo
    Jun 9, 2021 at 17:00
  • This worked for me, thank you.
    – singrium
    Nov 21, 2021 at 18:26
  • It was enough just to restart bluetooth module with sudo systemctl restart bluetooth Jan 11 at 7:22
8

I am not able to comment on the top response, but I thought I'd add that on my Ubuntu MATE 12.04 LTS Laptop, I had to do:

sudo apt-get install pulseaudio-module-bluetooth

only then did this work

sudo -i pactl load-module module-bluetooth-discover

Then I had to go into bluetooth manager app, pair the device, then set to 'Audio Sink' mode, then I could see the device within the Ubuntu Sound options and manipulate inputs/outputs!

0
6

The permanent solution would be to add the blueman PPA and update your package to the latest version which has the bug fixed: https://launchpad.net/~blueman/+archive/ubuntu/ppa

sudo add-apt-repository ppa:blueman/ppa
sudo apt-get update
sudo apt-get upgrade

That way, you should no longer have to run the

sudo -i pactl load-module module-bluetooth-discover

command every time but only once. Works for me on 14.04 LTS (Trusty)

Source

2
  • This does not apply for 16.04. The repository has no release candidate for it.
    – k0pernikus
    Jan 6, 2017 at 14:57
  • @k0pernikus Seems like you can just sudo apt install blueman directly in 16.04: askubuntu.com/questions/764273/…
    – Andrew Mao
    Dec 11, 2017 at 19:28

Not the answer you're looking for? Browse other questions tagged or ask your own question.