So I just got alongside my Windows 8.1 a cool Ubuntu 14.04 and quite happy with it (my default OS now). I just have a problem: the fact that I can't mount ext4 partitions at boot is quite annoying. I have the following setup: 1x Intel SSD with 3 partitions: the root ext4 (ubuntu install point), a NTFS one (where the win 8.1 lives) and the swap. Everything on this disk mounts at startup by default, without problems (the root mounts, obviously, swap works, and the NTFS automatically mounts and shows up in Nautilus). I also have other 2 HDD disks. Both have one ext4 partition and one NTFS. I tried making them mount at startup using the Disks app. I made identical settings to all of them, the NTFS ones mount, the ext4 give an error. I'll explain with screenshots:

This is how the default automount for my root ext4 looks (and perfectly works).

Screenshot 1

This is how I set up the NTFS partitions, that perfectly auto mount: enter image description here

And this is how I am trying to set up my ext4 partitions to mount at startup:
By default, the mount setup for non-boot ext4's looks like this: enter image description here

I try setting it up like this: enter image description here

OK for now,...it asks for password:enter image description here

Now it looks like everything worked: enter image description here

But the partition will not mount. If I restart my PC or I try to use the ext4 partition set to automount, I get: enter image description here

And I am unable to use my partitions until i go to disks and set them to automatic mount options again. Also, if i set up and restart without remounting, before I get to my desktop, I get that error on the last screenshot with the "Bad superblock".

I know this question has been asked, but no one had the exact problem as me, and some say it is impossible to fix? I don't believe that. On my server I setup automount with fstab. I can do this here, but i need to keep the EXACT labels and mountpoints because I have some path dependent applications like Deluge. Thanks.

  • hi, may I ask you one thing off topic? which system load indicator is that..?
    – Blue_Alien
    Dec 26, 2015 at 17:40

2 Answers 2


You need to edit your /etc/fstab file.

First open a terminal and type sudo blkid. This will list all your disks. Note the UUIDs of the partitions you want to automount.

Second, type sudo gedit /etc/fstab

Add a line for each partition as follows:

UUID=your-UUID-here /media/mount-point ext4 defaults 0 1

Change UUID and mount point as desired.

Logout and in again.

  • Ok and will it show up in nautilus sidebar if I do this? I tried with the mount command and my partitions were showing up as regular folders only. Is anything different with fstab? Or I need to put some extra arguments to make it show as partition in file manager?
    – Bodo
    Jun 12, 2014 at 4:06
  • It will show in Nautilus devices list if you set the mount point to something under /media
    – To Do
    Jun 12, 2014 at 6:56

The "Disks" utility is a front end for fstab! The issue you're having is that "nosuid,nodev,nofail,x-gvfs-show" doesn't seem to work with ext4, change to "defaults" and it should work fine!

Had exactly the same issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.