3

I have a Brother MFC-J470DW printer that I have connected to a Linux desktop (running Ubuntu 14.04) using a wireless router network. The printer works fine for printing and copying, but now I want to add the scan function.

To set up the scan function, I went to the Brother web page Downloads for this printer:

and under Scanner Drivers selected "Scanner driver 64bit (deb package)", "Scan-key-tool 64bit (deb package)", and "Scanner Setting file (deb package)". For each package, I accepted the EULA, and selected "open with Ubuntu Software Center". Then after the USC window pops up, I click on Install and the red line goes from left to right. In each case, the USC window then had a green check mark and the Install box changes to Reinstall (that's how you know it worked).

So now I try it out. Hitting the Scan button on the printer, selecting "Scan to file", and hitting OK produces the message "Check Connection".

I checked the Brother Linux Information FAQ (scanner) page and the 14th question seems the same as mine:

    When I try to use the scan key on my network connected
    machine, I receive the error "Check connection" or I can not
    select anything except "scan to FTP".

I explored the solution given for this FAQ, but found from ifconfig that I am already using eth0, the default setting, so presumably that is not the problem.

I also found brscan-skey installed in /usr/bin and did

drrm@drrmlinux2:~$ brscan-skey -t
drrm@drrmlinux2:~$ brscan-skey

but that didn't help - I still get the "Check connection" message.

What can you suggest to fix this problem?


Brother released an upgrade for scan driver dated 05/06/2014. I installed, but still get the "Check Connection" message. On the downloads page (deb version), they also still state the release date as 12/03/2014 for the scan-key-tool 64-bit and scanner settings file packages, which has not changed. So maybe I just have to wait some months to see if the release date of these other packages changes.

  • As a first-time user of askubuntu, I am completely confused. I asked a question, got a proposed solution yesterday, which now seems to have disappeared, and added a comment that the proposed solution did not work, which has also disappeared. I have no idea of what to do. – user292599 Jun 13 '14 at 13:00
  • Scanning in Ubuntu does not work like that with the press of a button in the printer. Open the application Simple Scan in Ubuntu and use it to scan the document. – user68186 Nov 19 '15 at 13:06
  • These low-end Brother printers don't allow scan to email directly. They rely on running applications on pc or phones to receive scanned files and (maybe) attach them to emails after launching the default mail application. What's baffling is that the web interface let you configure the SMTP server until the very last step (including auth verification step), but the scan key can't be configured to send an email directly. – Avio Mar 20 '17 at 10:43
0

I fixed my scanning issue by typing in View Local Services, find Windows Image Acquisition (WIA), click on Log On, set Long on as: to Local System account with Allow service to interact with desktop checked, click OK.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.