6

I have installed Ubuntu Gnome 14.04

The problem is :

Nautilus(I think it called "Files" in gnome-shell) has no Minimize/Maximize button !

I have enabled gnome-tweak-tool -> Windows -> Maximized/Minimized, but Nautilus has not Minimize/Maximize buttons!

enter image description here

Any ideas?

6
  • did you follow this workaround askubuntu.com/questions/125765/…
    – JoKeR
    Jun 11 '14 at 9:37
  • Yes I did, but problem doesn't solved Jun 11 '14 at 9:45
  • I just logged into Gnome-shell using dconf as instructed in answer 2 works right away. Oh yeah, pardon, but you meant Nautilus also :-) let me check next
    – JoKeR
    Jun 11 '14 at 9:48
  • I exactly did instructed in answer 2 it works fine for all windows but nautilus ! Jun 11 '14 at 9:51
  • 1
    You can always press Alt+ Space to bring up window menu, and select minimize.
    – No Time
    Dec 15 '14 at 2:55
2

hm... Actually there's an option for minimize/maximize it's kinda hidden, when you click on nautilus top panel you get:

enter image description here

I'll add more solutions, when/if I find.

3
  • 2
    I know that, not interesting... Jun 11 '14 at 10:18
  • oh :-) ok, I didn't know you already know that.
    – JoKeR
    Jun 11 '14 at 10:18
  • 3
    so, I did some deep research including Gnome official sources, and currently it's not possible to do with Gnome 3.10+ only the way like on the screenshot, not even adding extensions will help you to add minimize/maximize buttons. Only if you install/replace to other file browser. I guess this be fixed but it's a question to Gnome developers.
    – JoKeR
    Jun 11 '14 at 13:51
0

So I just noticed that you used tweak tool but didn't notice you are asking about Nautilus. As far as I know after I did some research before that you can't do that. You can look on this extension or you can try Nemo. I personally use keyboard shortcuts to navigate.

3
  • window placement has nothing to do with buttons:-)
    – JoKeR
    Jun 11 '14 at 13:47
  • I use native windows placement plus keyboard shortcuts and I never felt like I need these buttons :p I already said with Nautilus it can't be done in Gnome 3 ;)
    – OdinRW
    Jun 12 '14 at 0:08
  • Apparently your research is 3 hours late than my answer :p
    – OdinRW
    Jun 12 '14 at 0:09
0

Install Elementary theme (ftom Elementary OS). This will move close button to the left corner and appear maximize in right.

You will get like this:

But if you select other themes after Elementary theme, layout don't save and will back to default in the next log in. I think, it possible to copy layput settings from Elementary theme and put it in any other.

0

Solved mine with

gsettings set org.gnome.desktop.wm.preferences button-layout ":minimize,maximize,close"

gsettings is a command line tool, by using it we are setting the property of desktop window manager's button layout to ":minimize,maximize,close" which will then have all three buttons instead of only close i.e a cross button

1
  • A little explanation would be useful. What does the command do, why it will work..etc.
    – Ron
    Jan 26 '16 at 17:51
0

enter image description here

On 20.04

Change or remove the shortcut for settings->toggle maximization state

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.