3

My sound menu integration of VLC seems to be broken (see screenshot), also the multimedia keys do not work any more. Is there a package I am missing?! The back forward buttons in the sound menu do not work either. I'm running VLC version 2.1.4

  • Other players work as expected (such as gnome-mplayer)

  • I'm running 14.04, before everything worked fine...

enter image description here

Edit:Output of dpkg -l vlc*

ii  vlc            2.1.4-0ubunt amd64        multimedia player and streamer
ii  vlc-data       2.1.4-0ubunt all          Common data for VLC
ii  vlc-nox        2.1.4-0ubunt amd64        multimedia player and streamer (w
ii  vlc-plugin-not 2.1.4-0ubunt amd64        LibNotify plugin for VLC
ii  vlc-plugin-pul 2.1.4-0ubunt amd64        PulseAudio plugin for VLC

Edit2:

Since there seems to be no obvious solution to that problem, I submitted a bug report: https://bugs.launchpad.net/ubuntu/+source/indicator-sound/+bug/1331460

  • Try logging in with the guest account, and see if it works there. If it does, then something is wrong with your configuration. – lenooh Jun 11 '14 at 13:48
  • I am facing exactly the same problem. Did you manage to find a solution? – orschiro Dec 21 '16 at 8:13
5
+50
  • Reinstall VLC:

    sudo apt-get remove --purge vlc vlc-data vlc-nox
    sudo apt-get install vlc vlc-data vlc-nox
    
  • Verify DBus plugin for VLC:

    $ ls -l /usr/lib/vlc/plugins/control/libdbus_plugin.so
    -rw-r--r-- 1 root root 72760 May 17 15:56 /usr/lib/vlc/plugins/control/libdbus_plugin.so
    

    VLC → Tools → Plugins & Extensions → Plugins tab → Is there D-Bus control interface?

  • Run VLC and check if it creates an MPRIS DBus service, example:

    $ gdbus call --session --dest org.freedesktop.DBus \
    --object-path / --method org.freedesktop.DBus.ListNames | \
    awk 'BEGIN { RS=","; } /org.mpris.MediaPlayer2./ { gsub(/[\[\]()\x27]/, ""); print $1; }'
    
    org.mpris.MediaPlayer2.vlc
    org.mpris.MediaPlayer2.vlc.instance18027
    

    (Try also with other working player, to confirm that you run the command correctly)

    Other way, you may use qdbusviewer → session bus tab → search for vlc

  • If DBus interface listed, check if VLC respond correctly:

    gdbus call --session \
        --dest org.mpris.MediaPlayer2.vlc \
        --object-path /org/mpris/MediaPlayer2 \
        --method org.freedesktop.DBus.Properties.Get \
        "org.mpris.MediaPlayer2.Player" \
        "PlaybackStatus"
    

    Output may be: (<'Playing'>,), (<'Paused'>,) or (<'Stopped'>,)

    or using qdbus

    qdbus org.mpris.MediaPlayer2.vlc \
        /org/mpris/MediaPlayer2 \
        org.freedesktop.DBus.Properties.Get \
        org.mpris.MediaPlayer2.Player PlaybackStatus
    

    It should output: Playing , Paused or Stopped

At this point, VLC player works as it should. So it is out of circle.

  • Reinstall indicator-sound and reset its config:

    sudo apt-get remove --purge indicator-sound
    sudo apt-get install indicator-sound unity-control-center unity-control-center-signon webaccounts-extension-common xul-ext-webaccounts
    
    dconf reset -f /com/canonical/indicator/sound/
    rm -rf ~/.cache/indicators/sound
    

    pkill -f indicator-sound-service or Logout/login

  • No success, run it in terminal & watch for errors

    Locate its executable:

    $ sudo updatedb
    $ locate -br indicator-sound-service$
    /usr/lib/x86_64-linux-gnu/indicator-sound/indicator-sound-service
    

    Rename it, to stop respawn, then kill its running process:

    sudo mv /usr/lib/x86_64-linux-gnu/indicator-sound/indicator-sound-service /usr/lib/x86_64-linux-gnu/indicator-sound/indicator-sound-service0
    pkill -f indicator-sound-service
    

    Run it again:

    /usr/lib/x86_64-linux-gnu/indicator-sound/indicator-sound-service0
    

    Run VLC, try use its control on sound menu, any error messages?

  • Try build new indicator-sound from source:

    sudo apt-get build-dep indicator-sound
    apt-get source indicator-sound
    cd indicator-sound-12.10.2+14.04.20140313/
    mkdir build
    cd build/
    cmake ..
    make
    

    Stop running one as previous step, then run without installing it:

    ./src/indicator-sound-service
    
| improve this answer | |
  • The weirdest thing is, that all the other players work as expected... If I want to file a bug report, for which package should i file it? What do you suggest? Thanks for the help, if there's no better answer coming I'm going to accept yours... – wa4557 Jun 16 '14 at 21:33
  • @wa4557, indicator-sound as VLC is stand alone foreign app, and the bug effects appear on sound menu. I suggest leaving it open (unaccepted). no other idea – user.dz Jun 16 '14 at 21:53
  • @wa4557, I saw the bug report be orphan (both packages set a invalid :/) . What's output of gdbus call --session --dest org.mpris.MediaPlayer2.vlc --object-path /org/mpris/MediaPlayer2 --method org.freedesktop.DBus.Properties.Get 'org.mpris.MediaPlayer2.Player' 'CanControl' – user.dz Jun 23 '14 at 19:11
0

Inside VLC go to :

Tools > Preferences, select "All" under "Show settings" (bottom left), then navigate to Interface > Control Interface and check the box next to "D-Bus control interface"

| improve this answer | |
  • there is no such setting for vlc 2.1. – wa4557 Jun 14 '14 at 14:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.